summaryrefslogtreecommitdiffstats
path: root/meta-microblaze
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-04-30 14:17:08 -0600
committerMark Hatle <mark.hatle@amd.com>2024-05-01 14:01:16 -0600
commitfa7fc711d6a7e07c09927caa3f459a8a3bb04aed (patch)
treeeb9eb7e20b0db4c993f8e993c357954ebef14711 /meta-microblaze
parent7965de51f877c3dff9f9ca08a2f95cc80b0ed598 (diff)
downloadmeta-xilinx-fa7fc711d6a7e07c09927caa3f459a8a3bb04aed.tar.gz
attr: Add microblaze symver workaround
Microblaze does not support symver, so disable this code. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-microblaze')
-rw-r--r--meta-microblaze/recipes-support/attr/attr/microblaze-symver.patch32
-rw-r--r--meta-microblaze/recipes-support/attr/attr_%.bbappend2
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-microblaze/recipes-support/attr/attr/microblaze-symver.patch b/meta-microblaze/recipes-support/attr/attr/microblaze-symver.patch
new file mode 100644
index 00000000..0db401d0
--- /dev/null
+++ b/meta-microblaze/recipes-support/attr/attr/microblaze-symver.patch
@@ -0,0 +1,32 @@
1Fix build failure
2
3On microblaze, we get a failure due to:
4
5 ../attr-2.5.2/libattr/syscalls.c:133:10: error: symver is only supported on ELF platforms
6
7Upstream-Status: Pending
8
9Signed-off-by: Mark Hatle <mark.hatle@amd.com>
10
11Index: attr-2.5.2/libattr/syscalls.c
12===================================================================
13--- attr-2.5.2.orig/libattr/syscalls.c
14+++ attr-2.5.2/libattr/syscalls.c
15@@ -31,6 +31,7 @@
16 * prefer symver attribute if available (since gcc 10),
17 * fall back to traditional .symver asm directive otherwise.
18 */
19+#ifndef __microblaze__
20 #ifdef __has_attribute
21 # if __has_attribute(__symver__)
22 # define SYMVER(cn, vn) __typeof(cn) cn __attribute__((__symver__(vn)))
23@@ -43,6 +44,9 @@
24 __asm__(".symver " #cn "," vn)
25 # endif
26 #endif
27+#else
28+# define SYMVER(cn, vn)
29+#endif
30 #ifndef SYMVER
31 # define SYMVER(cn, vn) __asm__(".symver " #cn "," vn)
32 #endif
diff --git a/meta-microblaze/recipes-support/attr/attr_%.bbappend b/meta-microblaze/recipes-support/attr/attr_%.bbappend
new file mode 100644
index 00000000..75c3696e
--- /dev/null
+++ b/meta-microblaze/recipes-support/attr/attr_%.bbappend
@@ -0,0 +1,2 @@
1FILESEXTRAPATHS:append:microblaze := ":${THISDIR}/attr"
2SRC_URI:append:microblaze = " file://microblaze-symver.patch"