summaryrefslogtreecommitdiffstats
path: root/meta-microblaze
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-09-22 18:34:28 -0700
committerMark Hatle <mark.hatle@amd.com>2022-09-22 18:34:28 -0700
commitb424df35d2a6f8b8f7d87abbf6bd1150a2ab221f (patch)
tree6cb771235302983f0b06977de31a1cdb474a16a3 /meta-microblaze
parent36428595d7da5a18ebf5ec173ecfbfc8bb7c73cb (diff)
downloadmeta-xilinx-b424df35d2a6f8b8f7d87abbf6bd1150a2ab221f.tar.gz
newlib/libgloss: Rebase patch for current version
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-microblaze')
-rw-r--r--meta-microblaze/recipes-core/newlib/files/0001-Patch-microblaze-Add-config-microblaze.mt-for-target.patch28
-rw-r--r--meta-microblaze/recipes-core/newlib/files/0003-LOCAL-Add-missing-declarations-for-xil_printf-to-std.patch15
2 files changed, 18 insertions, 25 deletions
diff --git a/meta-microblaze/recipes-core/newlib/files/0001-Patch-microblaze-Add-config-microblaze.mt-for-target.patch b/meta-microblaze/recipes-core/newlib/files/0001-Patch-microblaze-Add-config-microblaze.mt-for-target.patch
index 14e162a5..ad2f0270 100644
--- a/meta-microblaze/recipes-core/newlib/files/0001-Patch-microblaze-Add-config-microblaze.mt-for-target.patch
+++ b/meta-microblaze/recipes-core/newlib/files/0001-Patch-microblaze-Add-config-microblaze.mt-for-target.patch
@@ -24,11 +24,10 @@ Signed-off-by: David Holsgrove <david.holsgrove@xilinx.com>
24 3 files changed, 32 insertions(+), 2 deletions(-) 24 3 files changed, 32 insertions(+), 2 deletions(-)
25 create mode 100644 libgloss/config/microblaze.mt 25 create mode 100644 libgloss/config/microblaze.mt
26 26
27diff --git a/libgloss/config/microblaze.mt b/libgloss/config/microblaze.mt 27Index: newlib-4.2.0.20211231/libgloss/config/microblaze.mt
28new file mode 100644 28===================================================================
29index 000000000..e8fb922dd
30--- /dev/null 29--- /dev/null
31+++ b/libgloss/config/microblaze.mt 30+++ newlib-4.2.0.20211231/libgloss/config/microblaze.mt
32@@ -0,0 +1,30 @@ 31@@ -0,0 +1,30 @@
33+# 32+#
34+# Match default.mt to compile generic objects but continue building 33+# Match default.mt to compile generic objects but continue building
@@ -60,11 +59,11 @@ index 000000000..e8fb922dd
60+ $(CC) $(CFLAGS_FOR_TARGET) -O2 $(INCLUDES) -c $(CFLAGS) $? 59+ $(CC) $(CFLAGS_FOR_TARGET) -O2 $(INCLUDES) -c $(CFLAGS) $?
61+write.o: ${srcdir}/../write.c 60+write.o: ${srcdir}/../write.c
62+ $(CC) $(CFLAGS_FOR_TARGET) -O2 $(INCLUDES) -c $(CFLAGS) $? 61+ $(CC) $(CFLAGS_FOR_TARGET) -O2 $(INCLUDES) -c $(CFLAGS) $?
63diff --git a/libgloss/microblaze/configure b/libgloss/microblaze/configure 62Index: newlib-4.2.0.20211231/libgloss/microblaze/configure
64index 9b2bc7ab4..01f0fb29d 100644 63===================================================================
65--- a/libgloss/microblaze/configure 64--- newlib-4.2.0.20211231.orig/libgloss/microblaze/configure
66+++ b/libgloss/microblaze/configure 65+++ newlib-4.2.0.20211231/libgloss/microblaze/configure
67@@ -2020,7 +2020,7 @@ LIB_AM_PROG_AS 66@@ -2550,7 +2550,7 @@ test "${CCASFLAGS+set}" = set || CCASFLA
68 67
69 68
70 host_makefile_frag=${srcdir}/../config/default.mh 69 host_makefile_frag=${srcdir}/../config/default.mh
@@ -73,10 +72,10 @@ index 9b2bc7ab4..01f0fb29d 100644
73 72
74 host_makefile_frag_path=$host_makefile_frag 73 host_makefile_frag_path=$host_makefile_frag
75 74
76diff --git a/libgloss/microblaze/configure.in b/libgloss/microblaze/configure.in 75Index: newlib-4.2.0.20211231/libgloss/microblaze/configure.ac
77index 77aa769d4..5d179fdfc 100644 76===================================================================
78--- a/libgloss/microblaze/configure.in 77--- newlib-4.2.0.20211231.orig/libgloss/microblaze/configure.ac
79+++ b/libgloss/microblaze/configure.in 78+++ newlib-4.2.0.20211231/libgloss/microblaze/configure.ac
80@@ -35,7 +35,7 @@ LIB_AM_PROG_AS 79@@ -35,7 +35,7 @@ LIB_AM_PROG_AS
81 AC_SUBST(bsp_prefix) 80 AC_SUBST(bsp_prefix)
82 81
@@ -86,6 +85,3 @@ index 77aa769d4..5d179fdfc 100644
86 85
87 dnl We have to assign the same value to other variables because autoconf 86 dnl We have to assign the same value to other variables because autoconf
88 dnl doesn't provide a mechanism to substitute a replacement keyword with 87 dnl doesn't provide a mechanism to substitute a replacement keyword with
89--
902.17.1
91
diff --git a/meta-microblaze/recipes-core/newlib/files/0003-LOCAL-Add-missing-declarations-for-xil_printf-to-std.patch b/meta-microblaze/recipes-core/newlib/files/0003-LOCAL-Add-missing-declarations-for-xil_printf-to-std.patch
index 3ecad637..06f797cb 100644
--- a/meta-microblaze/recipes-core/newlib/files/0003-LOCAL-Add-missing-declarations-for-xil_printf-to-std.patch
+++ b/meta-microblaze/recipes-core/newlib/files/0003-LOCAL-Add-missing-declarations-for-xil_printf-to-std.patch
@@ -9,20 +9,17 @@ Signed-off-by: David Holsgrove <david.holsgrove@xilinx.com>
9 newlib/libc/include/stdio.h | 3 +++ 9 newlib/libc/include/stdio.h | 3 +++
10 1 file changed, 3 insertions(+) 10 1 file changed, 3 insertions(+)
11 11
12diff --git a/newlib/libc/include/stdio.h b/newlib/libc/include/stdio.h 12Index: newlib-4.2.0.20211231/newlib/libc/include/stdio.h
13index ab18806e3..8240dd8ab 100644 13===================================================================
14--- a/newlib/libc/include/stdio.h 14--- newlib-4.2.0.20211231.orig/newlib/libc/include/stdio.h
15+++ b/newlib/libc/include/stdio.h 15+++ newlib-4.2.0.20211231/newlib/libc/include/stdio.h
16@@ -245,6 +245,9 @@ int sprintf (char *__restrict, const char *__restrict, ...) 16@@ -245,6 +245,9 @@ int sprintf (char *__restrict, const cha
17 _ATTRIBUTE ((__format__ (__printf__, 2, 3))); 17 _ATTRIBUTE ((__format__ (__printf__, 2, 3)));
18 int remove (const char *); 18 int remove (const char *);
19 int rename (const char *, const char *); 19 int rename (const char *, const char *);
20+void xil_printf (const char*, ...); 20+void xil_printf (const char*, ...);
21+void putnum (unsigned int ); 21+void putnum (unsigned int );
22+void print (const char* ); 22+void print (const char* );
23 #ifdef _COMPILING_NEWLIB 23 #ifdef _LIBC
24 int _rename (const char *, const char *); 24 int _rename (const char *, const char *);
25 #endif 25 #endif
26--
272.17.1
28