summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-08-24 07:50:23 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-28 08:18:40 -0700
commit9fed01fc8b1559a73144d00ff6506484ca416dd7 (patch)
tree0f63bf562fbc84a061b3c85141ad203ea56f267f /meta-microblaze/recipes-devtools
parent4a926c637180679dd1a31aebc4b808cb132f1bc6 (diff)
downloadmeta-xilinx-9fed01fc8b1559a73144d00ff6506484ca416dd7.tar.gz
Revert "gcc: Fix performance degradation on Microblaze 64"
This reverts commit 1bb08d385a4dbd1a3bf07a3917ea32f4be91ffac. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-microblaze/recipes-devtools')
-rw-r--r--meta-microblaze/recipes-devtools/gcc/gcc-10/0056-Patch-MicroBlaze-Added-zero_extendqidi2-and-zero_ext.patch51
-rw-r--r--meta-microblaze/recipes-devtools/gcc/gcc-source_11.%.bbappend1
2 files changed, 0 insertions, 52 deletions
diff --git a/meta-microblaze/recipes-devtools/gcc/gcc-10/0056-Patch-MicroBlaze-Added-zero_extendqidi2-and-zero_ext.patch b/meta-microblaze/recipes-devtools/gcc/gcc-10/0056-Patch-MicroBlaze-Added-zero_extendqidi2-and-zero_ext.patch
deleted file mode 100644
index 0af64096..00000000
--- a/meta-microblaze/recipes-devtools/gcc/gcc-10/0056-Patch-MicroBlaze-Added-zero_extendqidi2-and-zero_ext.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 9ffd7d3ba55a9dc63093f16a02b8d5634ffd2a39 Mon Sep 17 00:00:00 2001
2From: Mahesh Bodapati <mbodapat@xilinx.com>
3Date: Wed, 11 Aug 2021 15:31:47 +0530
4Subject: [PATCH] [Patch,MicroBlaze] : Added zero_extendqidi2 and
5 zero_extendhidi2 patterns to resolve TSR-974519. in GCC 10.2,commit
6 0a237a94c206b53eb: Do not propagate results from inner REGS to paradoxical
7 SUBREGs and this commit is causing the MB 64 compiler to generate extra
8 instructions.
9
10---
11 gcc/config/microblaze/microblaze.md | 24 ++++++++++++++++++++++++
12 1 file changed, 24 insertions(+)
13
14diff --git a/gcc/config/microblaze/microblaze.md b/gcc/config/microblaze/microblaze.md
15index 71ac46dfb6c..b34e963e176 100644
16--- a/gcc/config/microblaze/microblaze.md
17+++ b/gcc/config/microblaze/microblaze.md
18@@ -1191,6 +1191,30 @@
19 (set_attr "mode" "SI,SI,SI")
20 (set_attr "length" "4,4,8")])
21
22+(define_insn "zero_extendhidi2"
23+ [(set (match_operand:DI 0 "register_operand" "=d,d,d")
24+ (zero_extend:DI (match_operand:HI 1 "nonimmediate_operand" "d,R,m")))]
25+ "TARGET_MB_64"
26+ "@
27+ andli\t%0,%1,0xffff
28+ lhu%i1\t%0,%1
29+ lhu%i1\t%0,%1"
30+ [(set_attr "type" "no_delay_arith,load,no_delay_load")
31+ (set_attr "mode" "DI,DI,DI")
32+ (set_attr "length" "8,4,8")])
33+
34+(define_insn "zero_extendqidi2"
35+ [(set (match_operand:DI 0 "register_operand" "=d,d,d")
36+ (zero_extend:DI (match_operand:QI 1 "nonimmediate_operand" "d,R,m")))]
37+ "TARGET_MB_64"
38+ "@
39+ andli\t%0,%1,0x00ff
40+ lbu%i1\t%0,%1
41+ lbu%i1\t%0,%1"
42+ [(set_attr "type" "arith,load,no_delay_load")
43+ (set_attr "mode" "DI,DI,DI")
44+ (set_attr "length" "4,4,8")])
45+
46 ;;----------------------------------------------------------------
47 ;; Sign extension
48 ;;----------------------------------------------------------------
49--
502.17.1
51
diff --git a/meta-microblaze/recipes-devtools/gcc/gcc-source_11.%.bbappend b/meta-microblaze/recipes-devtools/gcc/gcc-source_11.%.bbappend
index d80469da..16c845cd 100644
--- a/meta-microblaze/recipes-devtools/gcc/gcc-source_11.%.bbappend
+++ b/meta-microblaze/recipes-devtools/gcc/gcc-source_11.%.bbappend
@@ -57,6 +57,5 @@ SRC_URI_append_microblaze = " \
57 file://0053-Patch-microblaze-Reducing-Stack-space-for-arguments.patch \ 57 file://0053-Patch-microblaze-Reducing-Stack-space-for-arguments.patch \
58 file://0054-Patch-MicroBlaze-Typo-in-the-previous-commits.bsefi-.patch \ 58 file://0054-Patch-MicroBlaze-Typo-in-the-previous-commits.bsefi-.patch \
59 file://0055-Patch-MicroBlaze.patch \ 59 file://0055-Patch-MicroBlaze.patch \
60 file://0056-Patch-MicroBlaze-Added-zero_extendqidi2-and-zero_ext.patch \
61 file://microblaze-mulitlib-hack.patch \ 60 file://microblaze-mulitlib-hack.patch \
62" 61"