summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-04-02 08:24:22 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-07-14 14:52:07 -0700
commitb2acbae49990a39002b67b1b9be22311e5cababf (patch)
tree84c40c9e277b647b0347c1786b0eed5cae302846 /meta-microblaze/recipes-core
parent4bacd51a73f3e66b855d94e67484ab049baeb934 (diff)
downloadmeta-xilinx-b2acbae49990a39002b67b1b9be22311e5cababf.tar.gz
libgloss: Fix crt*.o files that are stripped, when they shouldn't be
Issue: CR-1062133 For some reason libgloss installs the crt*.o files with executable bit set, this causes the build system to strip these as executables. However, it makes it impossible to use the .o files to properly link applications later on. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-microblaze/recipes-core')
-rw-r--r--meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend b/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
index 3dee0f06..e7f0a9a3 100644
--- a/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
+++ b/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
@@ -4,3 +4,10 @@ do_configure_prepend_microblaze() {
4 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC) 4 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC)
5 export CC="${CC} -L${S}/libgloss/microblaze" 5 export CC="${CC} -L${S}/libgloss/microblaze"
6} 6}
7
8# Libgloss provides various .o files in libdir
9# These must NOT be stripped, but for some reason they are installed +x
10# which triggers them to be stripped.
11do_install_append_microblaze() {
12 chmod 0644 ${D}${libdir}/*.o
13}