summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-12-02 04:37:36 -0800
committerMark Hatle <mark.hatle@xilinx.com>2022-01-14 11:21:55 -0800
commit45ef140975dd4bcba78ef8df0a9f0106caedabcd (patch)
treedc9b7d3a03ecaa3b0fde92313ba5ca41dc537253 /meta-microblaze/recipes-core
parentd20cf4ec0871bfeef4a1d68acd14fd3ee869fbc0 (diff)
downloadmeta-xilinx-45ef140975dd4bcba78ef8df0a9f0106caedabcd.tar.gz
microblaze libxcrypt: Fall back to older style symver support
Using symver related functions results in: | ../git/lib/crypt-static.c:32:1: error: symver is only supported on ELF platforms | 32 | SYMVER_crypt; | | ^~~~~~~~~~~~ Microblaze does not support these functions at this time, so fall back to the older approach to resolve this issue. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-microblaze/recipes-core')
-rw-r--r--meta-microblaze/recipes-core/libxcrypt/files/use-older-symver.patch15
-rw-r--r--meta-microblaze/recipes-core/libxcrypt/libxcrypt_%.bbappend4
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-microblaze/recipes-core/libxcrypt/files/use-older-symver.patch b/meta-microblaze/recipes-core/libxcrypt/files/use-older-symver.patch
new file mode 100644
index 00000000..4e6d5ecf
--- /dev/null
+++ b/meta-microblaze/recipes-core/libxcrypt/files/use-older-symver.patch
@@ -0,0 +1,15 @@
1Avoid an issue on microblaze where the symver attribute is not available.
2
3diff --git a/lib/crypt-port.h b/lib/crypt-port.h
4index 3fa5222..80c3d91 100644
5--- a/lib/crypt-port.h
6+++ b/lib/crypt-port.h
7@@ -208,7 +208,7 @@ extern size_t strcpy_or_abort (void *dst, size_t d_size, const void *src);
8
9 /* Starting with GCC 10, we can use the symver attribute, which is also
10 needed at the point we decide to enable link-time optimization. */
11-# if __GNUC__ >= 10
12+# if __GNUC__ >= 10 && ! defined (__MICROBLAZE__)
13
14 /* Set the symbol version for EXTNAME, which uses INTNAME as its
15 implementation. */
diff --git a/meta-microblaze/recipes-core/libxcrypt/libxcrypt_%.bbappend b/meta-microblaze/recipes-core/libxcrypt/libxcrypt_%.bbappend
new file mode 100644
index 00000000..3743e905
--- /dev/null
+++ b/meta-microblaze/recipes-core/libxcrypt/libxcrypt_%.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS:append:microblaze := ":${THISDIR}/files"
2SRC_URI:append:microblaze = " \
3 file://use-older-symver.patch \
4"