summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-04-15 19:29:37 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-04-26 15:33:30 +1000
commite448d3c1de3ce284ef42a591fd89cf4c2b6a81cf (patch)
treef4636fe64ed694d6033f2b33a29807467c30915c /conf
parentae22febf817ba9bee60014756e0d87f635f7e25f (diff)
downloadmeta-xilinx-e448d3c1de3ce284ef42a591fd89cf4c2b6a81cf.tar.gz
device-tree.bbappend: Move use of MACHINE_DEVICETREE to SRC_URI
Remove the use of MACHINE_DEVICETREE for providing sources to device-tree, instead provide the device tree sources as SRC_URI entires. Whilst this was already being done automatically by the MACHINE_DEVICETREE logic it also created a non-standard way of providing the device tree sources to the recipe. The setup of SRC_URI is done via the use of a device-tree.bbappend instead of directly in the device-tree.bb recipe itself. This is for two reason, separation of the source from the build logic as well as to provide an example for how a user can extend the device-tree recipe to provide custom device tree sources in their layer. This change also moves the paths to the sources around, this is to align the names of the directories to match the OVERRIDES so that when expanding the file paths it will search the subdirs based on the OVERRIDES or machine names. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/machine/kc705-microblazeel.conf4
-rw-r--r--conf/machine/microzed-zynq7.conf1
-rw-r--r--conf/machine/picozed-zynq7.conf1
-rw-r--r--conf/machine/qemu-zynq7.conf1
-rw-r--r--conf/machine/zybo-linux-bd-zynq7.conf6
5 files changed, 0 insertions, 13 deletions
diff --git a/conf/machine/kc705-microblazeel.conf b/conf/machine/kc705-microblazeel.conf
index cea1d173..efd83b78 100644
--- a/conf/machine/kc705-microblazeel.conf
+++ b/conf/machine/kc705-microblazeel.conf
@@ -15,10 +15,6 @@ USE_VT = ""
15SERIAL_CONSOLE = "115200 ttyS0" 15SERIAL_CONSOLE = "115200 ttyS0"
16 16
17MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 17MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
18MACHINE_DEVICETREE := " \
19 kc705/kc705-microblazeel.dts \
20 kc705/pl.dtsi \
21 kc705/system-conf.dtsi"
22 18
23EXTRA_IMAGEDEPENDS += "virtual/bitstream" 19EXTRA_IMAGEDEPENDS += "virtual/bitstream"
24 20
diff --git a/conf/machine/microzed-zynq7.conf b/conf/machine/microzed-zynq7.conf
index 9a00e61d..8e24d5f5 100644
--- a/conf/machine/microzed-zynq7.conf
+++ b/conf/machine/microzed-zynq7.conf
@@ -15,7 +15,6 @@ SPL_BINARY = "spl/boot.bin"
15SERIAL_CONSOLE = "115200 ttyPS0" 15SERIAL_CONSOLE = "115200 ttyPS0"
16 16
17MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 17MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
18MACHINE_DEVICETREE = "microzed/microzed-zynq7.dts"
19 18
20IMAGE_BOOT_FILES += "boot.bin ${MACHINE}.dtb" 19IMAGE_BOOT_FILES += "boot.bin ${MACHINE}.dtb"
21 20
diff --git a/conf/machine/picozed-zynq7.conf b/conf/machine/picozed-zynq7.conf
index 12b0fde2..e1d723c4 100644
--- a/conf/machine/picozed-zynq7.conf
+++ b/conf/machine/picozed-zynq7.conf
@@ -19,7 +19,6 @@ SPL_BINARY = "spl/boot.bin"
19SERIAL_CONSOLE = "115200 ttyPS0" 19SERIAL_CONSOLE = "115200 ttyPS0"
20 20
21MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 21MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
22MACHINE_DEVICETREE = "picozed/picozed-zynq7.dts"
23 22
24IMAGE_BOOT_FILES += "boot.bin ${MACHINE}.dtb" 23IMAGE_BOOT_FILES += "boot.bin ${MACHINE}.dtb"
25 24
diff --git a/conf/machine/qemu-zynq7.conf b/conf/machine/qemu-zynq7.conf
index e3cd575a..6d55f09d 100644
--- a/conf/machine/qemu-zynq7.conf
+++ b/conf/machine/qemu-zynq7.conf
@@ -11,7 +11,6 @@ MACHINE_FEATURES = "ext2 vfat"
11SERIAL_CONSOLE = "115200 ttyPS0" 11SERIAL_CONSOLE = "115200 ttyPS0"
12 12
13MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 13MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
14MACHINE_DEVICETREE = "qemu/qemu-zynq7.dts"
15 14
16# Use the networking setup from qemuarm 15# Use the networking setup from qemuarm
17FILESOVERRIDES_append_pn-init-ifupdown = ":qemuarm" 16FILESOVERRIDES_append_pn-init-ifupdown = ":qemuarm"
diff --git a/conf/machine/zybo-linux-bd-zynq7.conf b/conf/machine/zybo-linux-bd-zynq7.conf
index f5524c12..a5c572f6 100644
--- a/conf/machine/zybo-linux-bd-zynq7.conf
+++ b/conf/machine/zybo-linux-bd-zynq7.conf
@@ -17,12 +17,6 @@ SERIAL_CONSOLE = "115200 ttyPS0"
17 17
18MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 18MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
19 19
20MACHINE_DEVICETREE = " \
21 zybo-linux-bd/pcw.dtsi \
22 zybo-linux-bd/pl.dtsi \
23 zybo-linux-bd/zybo-linux-bd-zynq7.dts \
24 "
25
26UBOOT_MACHINE = "zynq_zybo_config" 20UBOOT_MACHINE = "zynq_zybo_config"
27SPL_BINARY = "spl/boot.bin" 21SPL_BINARY = "spl/boot.bin"
28FORCE_PS7INIT = "zybo" 22FORCE_PS7INIT = "zybo"