summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com>2023-01-12 15:33:01 -0700
committerMark Hatle <mark.hatle@amd.com>2023-04-10 09:03:22 -0700
commite053aff1585e91eeefd14df2af7e30a266d2cec5 (patch)
tree7e1abaf7d85fe8177873e8b5edf8cd3dd20a4f2b
parent84e209dfca2fd72d8ebc44a4c4a9faba5671d159 (diff)
downloadmeta-xilinx-e053aff1585e91eeefd14df2af7e30a266d2cec5.tar.gz
microblazeel: Update kc705 machine conf file using gen-machineconf tool
1. Update below microblazeel eval board machine conf file using gen-machineconf tool by parsing respective xsa. 2. Move variables which changes based on xsa before required inclusion file to handle pre-expansion values. Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com> 3. Remove kc705-bitstream, use standard bitstream-extraction now Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-bsp/conf/layer.conf2
-rw-r--r--meta-xilinx-bsp/conf/machine/kc705-microblazeel.conf50
-rw-r--r--meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.1.bb48
-rw-r--r--meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.2.bb48
4 files changed, 43 insertions, 105 deletions
diff --git a/meta-xilinx-bsp/conf/layer.conf b/meta-xilinx-bsp/conf/layer.conf
index 56a5bc29..051ca361 100644
--- a/meta-xilinx-bsp/conf/layer.conf
+++ b/meta-xilinx-bsp/conf/layer.conf
@@ -17,5 +17,3 @@ BBFILE_PRIORITY_xilinx-bsp = "5"
17LAYERDEPENDS_xilinx-bsp = "xilinx" 17LAYERDEPENDS_xilinx-bsp = "xilinx"
18 18
19LAYERSERIES_COMPAT_xilinx-bsp = "langdale" 19LAYERSERIES_COMPAT_xilinx-bsp = "langdale"
20
21PREFERRED_VERSION_kc705-bitstream ?= "${XILINX_RELEASE_VERSION}"
diff --git a/meta-xilinx-bsp/conf/machine/kc705-microblazeel.conf b/meta-xilinx-bsp/conf/machine/kc705-microblazeel.conf
index fa80b568..d312c07f 100644
--- a/meta-xilinx-bsp/conf/machine/kc705-microblazeel.conf
+++ b/meta-xilinx-bsp/conf/machine/kc705-microblazeel.conf
@@ -1,14 +1,50 @@
1#@TYPE: Machine 1#@TYPE: Machine
2#@NAME: kc705-microblazeel 2#@NAME: kc705-microblazeel
3#@DESCRIPTION: Machine support for Xilinx KC705 Embedded Kit. 3#@DESCRIPTION: Machine configuration for the KC705 evaluation board.
4#
5 4
6TUNE_FEATURES:tune-microblaze ?= "microblaze v11.0 barrel-shift reorder pattern-compare multiply-high divide-hard" 5#### Preamble
6MACHINEOVERRIDES =. "${@['', 'kc705-microblazeel:']['kc705-microblazeel' !='${MACHINE}']}"
7#### Regular settings follow
7 8
8require conf/machine/microblaze-generic.conf 9# Variables that changes based on hw design or board specific requirement must be
10# defined before calling the required inclusion file else pre-expansion value
11# defined in microblazeel-generic.conf will be set.
12
13# Yocto device-tree variables
14YAML_CONSOLE_DEVICE_CONFIG:pn-device-tree ?= "axi_uartlite_0"
15YAML_MAIN_MEMORY_CONFIG:pn-device-tree ?= "MIG_7SERIES_0"
16DT_PADDING_SIZE:pn-device-tree ?= "0x1000"
17DTC_FLAGS:pn-device-tree ?= ""
18XSCTH_PROC:microblaze:pn-device-tree ?= "microblaze_0"
19YAML_DT_BOARD_FLAGS ?= "{BOARD template}"
20
21# Yocto FS-Boot variables
22YAML_SERIAL_CONSOLE_STDIN:pn-fs-boot ?= "axi_uartlite_0"
23YAML_SERIAL_CONSOLE_STDOUT:pn-fs-boot ?= "axi_uartlite_0"
24YAML_MAIN_MEMORY_CONFIG:pn-fs-boot ?= "MIG_7SERIES_0"
25YAML_FLASH_MEMORY_CONFIG:pn-fs-boot ?= "axi_emc_0"
26XSCTH_PROC:pn-fs-boot ?= "microblaze_0"
27
28# Yocto KERNEL Variables
29UBOOT_ENTRYPOINT ?= "0x80000000"
30UBOOT_LOADADDRESS ?= "0x80000000"
9 31
10USE_VT = "" 32# Set DDR Base address for u-boot-xlnx-scr variables
33DDR_BASEADDR ?= "0x80000000"
34SKIP_APPEND_BASEADDR ?= "0"
35
36# kc705-microblazeel Serial Console
37SERIAL_CONSOLES ?= "115200;ttyUL0"
38YAML_SERIAL_CONSOLE_BAUDRATE ?= "115200"
39
40# Required generic machine inclusion
41require conf/machine/microblaze-generic.conf
11 42
12MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree" 43# This machine conf file uses kc705-microblazeel xsa as reference input.
44# User can override with kc705 custom xsa using HDF_BASE and HDF_PATH variables
45# from local.conf.
46HDF_MACHINE = "kc705-microblazeel"
13 47
14EXTRA_IMAGEDEPENDS += "virtual/bitstream virtual/bootloader" 48#### No additional settings should be after the Postamble
49#### Postamble
50PACKAGE_EXTRA_ARCHS:append = "${@['', 'kc705_microblazeel']['kc705-microblazeel' != '${MACHINE}']}"
diff --git a/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.1.bb b/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.1.bb
deleted file mode 100644
index e512777c..00000000
--- a/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.1.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SUMMARY = "KC705 Pre-built Bitstream"
2DESCRIPTION = "A Pre-built bitstream for the KC705, which is capable of booting a Linux system."
3HOMEPAGE = "http://www.xilinx.com"
4SECTION = "bsp"
5
6# The BSP package does not include any license information.
7LICENSE = "Proprietary"
8LICENSE_FLAGS = "xilinx"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
10
11COMPATIBLE_MACHINE = "kc705-microblazeel"
12
13inherit deploy
14inherit xilinx-fetch-restricted
15
16BSP_NAME = "xilinx-kc705"
17BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp"
18SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}"
19SRC_URI[md5sum] = "5c0365a8a26cc27b4419aa1d7dd82351"
20SRC_URI[sha256sum] = "a909a91a37a9925ee2f972ccb10f986a26ff9785c1a71a483545a192783bf773"
21
22PROVIDES = "virtual/bitstream"
23
24FILES:${PN} += "/boot/download.bit"
25
26INHIBIT_DEFAULT_DEPS = "1"
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29# deps needed to extract content from the .bsp file
30DEPENDS += "tar-native gzip-native"
31
32do_compile() {
33 # Extract the bitstream into workdir
34 tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-axi-full-${PV}/pre-built/linux/images/download.bit -C ${S}
35 # move the bit file to ${S}/ as it is in a subdir in the tar file
36 for i in $(find -type f -name download.bit); do mv $i ${S}; done
37}
38
39do_install() {
40 install -D ${S}/download.bit ${D}/boot/download.bit
41}
42
43do_deploy () {
44 install -D ${S}/download.bit ${DEPLOYDIR}/download.bit
45}
46
47addtask deploy before do_build after do_install
48
diff --git a/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.2.bb b/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.2.bb
deleted file mode 100644
index e512777c..00000000
--- a/meta-xilinx-bsp/recipes-bsp/reference-design/kc705-bitstream_2022.2.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SUMMARY = "KC705 Pre-built Bitstream"
2DESCRIPTION = "A Pre-built bitstream for the KC705, which is capable of booting a Linux system."
3HOMEPAGE = "http://www.xilinx.com"
4SECTION = "bsp"
5
6# The BSP package does not include any license information.
7LICENSE = "Proprietary"
8LICENSE_FLAGS = "xilinx"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
10
11COMPATIBLE_MACHINE = "kc705-microblazeel"
12
13inherit deploy
14inherit xilinx-fetch-restricted
15
16BSP_NAME = "xilinx-kc705"
17BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp"
18SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}"
19SRC_URI[md5sum] = "5c0365a8a26cc27b4419aa1d7dd82351"
20SRC_URI[sha256sum] = "a909a91a37a9925ee2f972ccb10f986a26ff9785c1a71a483545a192783bf773"
21
22PROVIDES = "virtual/bitstream"
23
24FILES:${PN} += "/boot/download.bit"
25
26INHIBIT_DEFAULT_DEPS = "1"
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29# deps needed to extract content from the .bsp file
30DEPENDS += "tar-native gzip-native"
31
32do_compile() {
33 # Extract the bitstream into workdir
34 tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-axi-full-${PV}/pre-built/linux/images/download.bit -C ${S}
35 # move the bit file to ${S}/ as it is in a subdir in the tar file
36 for i in $(find -type f -name download.bit); do mv $i ${S}; done
37}
38
39do_install() {
40 install -D ${S}/download.bit ${D}/boot/download.bit
41}
42
43do_deploy () {
44 install -D ${S}/download.bit ${DEPLOYDIR}/download.bit
45}
46
47addtask deploy before do_build after do_install
48