diff options
author | Ramya Darapuneni <ramya.darapuneni@amd.com> | 2024-04-29 18:19:52 +0530 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-04-29 14:12:46 -0500 |
commit | c5bde0cba28970488cfb366276ba7122c046e390 (patch) | |
tree | fddf4586f9a95eb856d0a21cb22373f7a40c67db | |
parent | 28c002e7d94b74a0ef917b6b71b1030b7376e32a (diff) | |
download | meta-xilinx-c5bde0cba28970488cfb366276ba7122c046e390.tar.gz |
bootgen: Add recipe for 2024.1
Updated latest branch commit id
Signed-off-by: Ramya Darapuneni <ramya.darapuneni@amd.com>
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r-- | meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb new file mode 100644 index 00000000..3c68f10d --- /dev/null +++ b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "Building and installing bootgen" | ||
2 | DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images" | ||
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1" | ||
6 | |||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | DEPENDS += "openssl" | ||
10 | RDEPENDS:${PN} += "openssl" | ||
11 | |||
12 | REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https" | ||
13 | BRANCH = "xlnx_rel_v2024.1" | ||
14 | SRCREV = "92e09bf37ea17d7b1f0e102a2548f27fb768651c" | ||
15 | |||
16 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | ||
17 | SRC_URI = "${REPO};${BRANCHARG}" | ||
18 | |||
19 | EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}' | ||
20 | CXXFLAGS:append = " -std=c++0x" | ||
21 | |||
22 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${bindir} | ||
26 | install -Dm 0755 ${S}/bootgen ${D}${bindir} | ||
27 | } | ||
28 | |||
29 | FILES:${PN} = "${bindir}/bootgen" | ||
30 | |||
31 | BBCLASSEXTEND = "native nativesdk" | ||