summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRamya Darapuneni <ramya.darapuneni@amd.com>2024-04-29 18:19:52 +0530
committerMark Hatle <mark.hatle@amd.com>2024-04-29 14:12:46 -0500
commitc5bde0cba28970488cfb366276ba7122c046e390 (patch)
treefddf4586f9a95eb856d0a21cb22373f7a40c67db
parent28c002e7d94b74a0ef917b6b71b1030b7376e32a (diff)
downloadmeta-xilinx-c5bde0cba28970488cfb366276ba7122c046e390.tar.gz
bootgen: Add recipe for 2024.1
Updated latest branch commit id Signed-off-by: Ramya Darapuneni <ramya.darapuneni@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb
new file mode 100644
index 00000000..3c68f10d
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/bootgen/bootgen_2024.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Building and installing bootgen"
2DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1"
6
7S = "${WORKDIR}/git"
8
9DEPENDS += "openssl"
10RDEPENDS:${PN} += "openssl"
11
12REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https"
13BRANCH = "xlnx_rel_v2024.1"
14SRCREV = "92e09bf37ea17d7b1f0e102a2548f27fb768651c"
15
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}"
18
19EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}'
20CXXFLAGS:append = " -std=c++0x"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install() {
25 install -d ${D}${bindir}
26 install -Dm 0755 ${S}/bootgen ${D}${bindir}
27}
28
29FILES:${PN} = "${bindir}/bootgen"
30
31BBCLASSEXTEND = "native nativesdk"