diff options
author | Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com> | 2023-08-10 16:35:22 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2023-08-14 10:16:29 -0500 |
commit | c38486bcf2512f3f5f56c735b4fdd65324480059 (patch) | |
tree | 341e7ebaf3617cc6453ee4e8970033a5631f49cf | |
parent | 986f2ff00bf94b5e3a24dc4993dd4b91eb56003b (diff) | |
download | meta-xilinx-c38486bcf2512f3f5f56c735b4fdd65324480059.tar.gz |
u-boot-xlnx-scr: Add variables for xen boot
Add variables for xen u-boot script and define in meta-virtualization
dynamic layer bbapends.
Variables are set wtih weak default assignment.
Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com>
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r-- | meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb index 76e074b4..5fe663d2 100644 --- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb +++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-scr.bb | |||
@@ -169,6 +169,15 @@ NAND_FIT_IMAGE_OFFSET ??= "0x4180000" | |||
169 | NAND_FIT_IMAGE_OFFSET:zynq ??= "0x1080000" | 169 | NAND_FIT_IMAGE_OFFSET:zynq ??= "0x1080000" |
170 | NAND_FIT_IMAGE_SIZE ??= "0x6400000" | 170 | NAND_FIT_IMAGE_SIZE ??= "0x6400000" |
171 | 171 | ||
172 | # Xen boot script variables. Define here and set it from meta-virtualization | ||
173 | XEN_OFFSET ??= "0xBA00000" | ||
174 | XEN_LOAD_ADDRESS ?= "${@append_baseaddr(d,d.getVar('XEN_OFFSET'))}" | ||
175 | XEN_IMAGE_NAME ??= "xen" | ||
176 | DOM0_MEM ??= "1500M" | ||
177 | XEN_SERIAL_CONSOLES ??= "serial0" | ||
178 | XEN_CMDLINE_APPEND ??= "" | ||
179 | DOM0_MAX_VCPUS ??= "1" | ||
180 | |||
172 | # Default to booting with the rootfs device being partition 2 for SD/eMMC | 181 | # Default to booting with the rootfs device being partition 2 for SD/eMMC |
173 | PARTNUM ?= "2" | 182 | PARTNUM ?= "2" |
174 | 183 | ||
@@ -245,6 +254,13 @@ do_compile() { | |||
245 | -e 's:@@KERNEL_ROOT_SD@@:${KERNEL_ROOT_SD}:' \ | 254 | -e 's:@@KERNEL_ROOT_SD@@:${KERNEL_ROOT_SD}:' \ |
246 | -e 's:@@KERNEL_ROOT_RAMDISK@@:${KERNEL_ROOT_RAMDISK}:' \ | 255 | -e 's:@@KERNEL_ROOT_RAMDISK@@:${KERNEL_ROOT_RAMDISK}:' \ |
247 | -e 's:@@KERNEL_COMMAND_APPEND@@:${KERNEL_COMMAND_APPEND}:' \ | 256 | -e 's:@@KERNEL_COMMAND_APPEND@@:${KERNEL_COMMAND_APPEND}:' \ |
257 | -e 's/@@XEN_IMAGE_NAME@@/${XEN_IMAGE_NAME}/' \ | ||
258 | -e 's/@@XEN_OFFSET@@/${XEN_OFFSET}/' \ | ||
259 | -e 's/@@XEN_LOAD_ADDRESS@@/${XEN_LOAD_ADDRESS}/' \ | ||
260 | -e 's/@@DOM0_MEM@@/${DOM0_MEM}/' \ | ||
261 | -e 's/@@DOM0_MAX_VCPUS@@/${DOM0_MAX_VCPUS}/' \ | ||
262 | -e 's:@@XEN_SERIAL_CONSOLES@@:${XEN_SERIAL_CONSOLES}:' \ | ||
263 | -e 's:@@XEN_CMDLINE_APPEND@@:${XEN_CMDLINE_APPEND}:' \ | ||
248 | "${WORKDIR}/boot.cmd.${BOOTMODE}${BOOTFILE_EXT}" > "${WORKDIR}/boot.cmd" | 264 | "${WORKDIR}/boot.cmd.${BOOTMODE}${BOOTFILE_EXT}" > "${WORKDIR}/boot.cmd" |
249 | 265 | ||
250 | mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr | 266 | mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr |