summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2012-10-05 10:51:43 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2012-10-05 10:51:43 +1000
commitc09b5c40b635559fbcc47de72bb528bae6fb8cc0 (patch)
tree78ea03d47d4dc3cfb5af8ed52ca98c59e1afb4c4
parent678832ca2b3f4e6f68a7114b1dd5a839bc3eaf1c (diff)
downloadmeta-xilinx-c09b5c40b635559fbcc47de72bb528bae6fb8cc0.tar.gz
db: Added patch to add "microblazeel" support to config.sub
Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rw-r--r--recipes-support/db/db_5.1.19.bbappend6
-rw-r--r--recipes-support/db/files/config-microblazeel.patch41
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-support/db/db_5.1.19.bbappend b/recipes-support/db/db_5.1.19.bbappend
new file mode 100644
index 00000000..3e5c9207
--- /dev/null
+++ b/recipes-support/db/db_5.1.19.bbappend
@@ -0,0 +1,6 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4# Apply patch to add "microblazeel" support to db
5SRC_URI += "file://config-microblazeel.patch"
6
diff --git a/recipes-support/db/files/config-microblazeel.patch b/recipes-support/db/files/config-microblazeel.patch
new file mode 100644
index 00000000..c4cc0f84
--- /dev/null
+++ b/recipes-support/db/files/config-microblazeel.patch
@@ -0,0 +1,41 @@
1Add "microblazeel" target to config.sub.
2
3--- dist/config.sub 2011-10-17 19:49:28.000000000 +1000
4+++ dist/config.sub 2012-10-04 16:43:53.250376336 +1000
5@@ -154,7 +154,7 @@
6 -convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
7 -c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
8 -harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
9- -apple | -axis | -knuth | -cray | -microblaze)
10+ -apple | -axis | -knuth | -cray | -microblaze | -microblazeel)
11 os=
12 basic_machine=$1
13 ;;
14@@ -260,7 +260,7 @@
15 | ip2k | iq2000 \
16 | lm32 \
17 | m32c | m32r | m32rle | m68000 | m68k | m88k \
18- | maxq | mb | microblaze | mcore | mep | metag \
19+ | maxq | mb | microblaze | microblazeel | mcore | mep | metag \
20 | mips | mipsbe | mipseb | mipsel | mipsle \
21 | mips16 \
22 | mips64 | mips64el \
23@@ -356,7 +356,7 @@
24 | lm32-* \
25 | m32c-* | m32r-* | m32rle-* \
26 | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
27- | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
28+ | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* | microblazeel-* \
29 | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
30 | mips16-* \
31 | mips64-* | mips64el-* \
32@@ -756,6 +756,9 @@
33 microblaze)
34 basic_machine=microblaze-xilinx
35 ;;
36+ microblazeel)
37+ basic_machine=microblazeel-xilinx
38+ ;;
39 mingw32)
40 basic_machine=i386-pc
41 os=-mingw32