summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2015-02-16 18:50:58 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2015-02-16 18:50:58 +1000
commitb32e1ccdc6419e0030636e94d2bb05c22e2fc510 (patch)
tree7b052f64fc8bef1fa40e487ad5a1021b9f4770a8
parentd4d16ccb2a0cfbd4781369b33be38ddb07c67bfd (diff)
downloadmeta-xilinx-b32e1ccdc6419e0030636e94d2bb05c22e2fc510.tar.gz
openssl: Patches no longer required
* Merged change to oe-core for MicroBlaze -> linux-generic32 detection Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rw-r--r--recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch26
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.%.bbappend3
2 files changed, 0 insertions, 29 deletions
diff --git a/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch b/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch
deleted file mode 100644
index 1723febb..00000000
--- a/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From: Nathan Rossi <nathan.rossi@xilinx.com>
2Subject: [PATCH] Add MicroBlaze Support
3
4Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
5Upstream-Status: Not Submitted
6---
7 Configure | 4 ++++
8 1 files changed, 4 insertions(+), 0 deletions(-)
9
10diff --git a/Configure b/Configure
11index 0c54d19..edaae47 100755
12--- a/Configure
13+++ b/Configure
14@@ -467,6 +467,10 @@ my %table=(
15 "linux-mips64el","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
16 "linux-mipsel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
17
18+#### Linux on MicroBlaze
19+"linux-microblaze","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
20+"linux-microblazeel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
21+
22 # Android: linux-* but without -DTERMIO and pointers to headers and libs.
23 "android","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
24 "android-x86","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:".eval{my $asm=${x86_elf_asm};$asm=~s/:elf/:android/;$asm}.":dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
25--
261.7.1
diff --git a/recipes-connectivity/openssl/openssl_1.0.%.bbappend b/recipes-connectivity/openssl/openssl_1.0.%.bbappend
deleted file mode 100644
index 4aeea009..00000000
--- a/recipes-connectivity/openssl/openssl_1.0.%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3SRC_URI_append += "file://Add-MicroBlaze-Support.patch"