summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2020-03-02 19:17:11 +0000
committerMark Hatle <mark.hatle@xilinx.com>2020-03-02 19:35:18 +0000
commita7035aa30dbe695ffd38175bd66932340302d2bd (patch)
treeb5f7fce646a2e5b0693f4cb6b6c78cf43e1ec7cc
parentdd988eeaeb532d788e5ec3c6ba20286a937573a4 (diff)
downloadmeta-xilinx-a7035aa30dbe695ffd38175bd66932340302d2bd.tar.gz
lopper: Add lopper utility
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
-rw-r--r--meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb b/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb
new file mode 100644
index 00000000..84b254d4
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Device tree lopper"
2DESCRIPTION = "Tool to subset a system device tree"
3SECTION = "bootloader"
4LICENSE = "BSD-3-Clause"
5DEPENDS += "python3-dtc"
6
7SRC_URI = "git://gitenterprise.xilinx.com/brucea/lopper.git"
8
9LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fe0b8a4beea8f0813b606d15a3df3d3c"
10
11SRCREV = "70cd4578c8a0ca202ea063cb83768267ea69dd2a"
12
13S = "${WORKDIR}/git"
14
15do_configure() {
16 :
17}
18
19do_compile() {
20 sed -i 's,#!/usr/bin/python3,#!/usr/bin/env python3,' lopper.py
21}
22
23do_install() {
24 datadirrelpath=${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}
25
26 mkdir -p ${D}/${bindir}
27 mkdir -p ${D}/${datadir}/lopper
28 cp -r ${S}/* ${D}/${datadir}/lopper/.
29 ln -s ${datadirrelpath}/lopper/lopper.py ${D}/${bindir}/.
30}
31
32BBCLASSEXTEND = "native nativesdk"