summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-04-19 13:22:20 -0600
committerMark Hatle <mark.hatle@amd.com>2024-04-19 14:34:37 -0600
commita21be031ba9618b3132a5c6313809f5435b98af6 (patch)
tree9ef1e6e86fcbfe87648dd7d8a47eed06f3e7e7cd
parent17b9bb3479db66061e566b87e5fa5dda62212584 (diff)
downloadmeta-xilinx-a21be031ba9618b3132a5c6313809f5435b98af6.tar.gz
u-boot-xlnx: Fix 2022.2 version and set defaults
2022.2 version was incorrectly specified before, fix this. Add the preferred_versions for u-boot related into conf/local.conf tied to the XILINX_RELEASE_VERSION. Add missing SRC_URI files as well. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/conf/layer.conf6
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.2.bb17
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic-top.h10
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic.cfg81
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2022.2.inc2
5 files changed, 113 insertions, 3 deletions
diff --git a/meta-xilinx-core/conf/layer.conf b/meta-xilinx-core/conf/layer.conf
index 993cd1bc..f7310bf1 100644
--- a/meta-xilinx-core/conf/layer.conf
+++ b/meta-xilinx-core/conf/layer.conf
@@ -65,8 +65,10 @@ XILINX_ATF_VERSION[v2023.1] = "2.8-xilinx-v2023.1%"
65XILINX_ATF_VERSION[v2023.2] = "2.8-xilinx-v2023.2%" 65XILINX_ATF_VERSION[v2023.2] = "2.8-xilinx-v2023.2%"
66PREFERRED_VERSION_arm-trusted-firmware ?= "${@d.getVarFlag('XILINX_ATF_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}" 66PREFERRED_VERSION_arm-trusted-firmware ?= "${@d.getVarFlag('XILINX_ATF_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}"
67 67
68XILINX_UBOOT_VERSION[v2023.1] = "v2023.01-xilinx-v2023.1%" 68XILINX_UBOOT_VERSION[v2022.1] = "1:v2021.01-xilinx-v2022.1%"
69XILINX_UBOOT_VERSION[v2023.2] = "v2023.01-xilinx-v2023.2%" 69XILINX_UBOOT_VERSION[v2022.2] = "1:v2022.01-xilinx-v2022.2%"
70XILINX_UBOOT_VERSION[v2023.1] = "1:v2023.01-xilinx-v2023.1%"
71XILINX_UBOOT_VERSION[v2023.2] = "1:v2023.01-xilinx-v2023.2%"
70 72
71PREFERRED_VERSION_u-boot-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}" 73PREFERRED_VERSION_u-boot-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}"
72PREFERRED_VERSION_u-boot-tools-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}" 74PREFERRED_VERSION_u-boot-tools-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}"
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.2.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.2.bb
index 44636872..6b033f0f 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.2.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.2.bb
@@ -19,3 +19,20 @@ do_compile () {
19 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B} 19 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B}
20} 20}
21 21
22# mkeficapsule is not available in this version of u-boot
23PROVIDES:remove = "${MLPREFIX}u-boot-mkeficapsule"
24PROVIDES:class-native:remove = "u-boot-mkeficapsule-native"
25PACKAGES:remove = "${PN}-mkeficapsule"
26RDEPENDS:${PN}:remove = "${PN}-mkeficapsule"
27
28do_install:prepend() {
29 # Avoid do_install failure
30 mkdir -p tools
31 touch tools/mkeficapsule
32}
33
34do_install:append() {
35 # Avoid failure
36 rm -rf ${D}${bindir}/uboot-mkeficapsule
37 rm -rf ${D}${bindir}/mkeficapsule
38}
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic-top.h b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic-top.h
new file mode 100644
index 00000000..08c1c16c
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic-top.h
@@ -0,0 +1,10 @@
1/*
2 * This file is use for addition u-boot configurations for microblaze.
3 */
4#include <configs/microblaze-generic.h>
5
6/* Core microblaze boot configurations */
7#define XILINX_USE_DCACHE 1
8#define CONFIG_CMD_IRQ
9#define CONFIG_DCACHE
10#define CONFIG_ICACHE \ No newline at end of file
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic.cfg b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic.cfg
new file mode 100644
index 00000000..0f784f73
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2022.01/microblaze-generic.cfg
@@ -0,0 +1,81 @@
1# SPDX-License-Identifier: MIT
2
3#........................................................................
4# WARNING
5#
6# This file is a u-boot configuration fragment, and not a full u-boot
7# configuration file. The final u-boot configuration is made up of
8# an assembly of processed fragments, each of which is designed to
9# capture a specific part of the final configuration (e.g. platform
10# configuration, feature configuration, and board specific hardware
11# configuration). For more information on u-boot configuration, please
12# refer the product documentation.
13#
14#.......................................................................
15
16#
17# Definitions for Generic Microbalze machine.
18#
19CONFIG_BOOTDELAY=4
20CONFIG_SYS_TEXT_BASE=0x80100000
21CONFIG_SYS_PROMPT="U-Boot>"
22CONFIG_SYS_CONFIG_NAME="microblaze-generic-top"
23CONFIG_BOOT_SCRIPT_OFFSET=0x1F00000
24# CONFIG_SYS_NS16550 is not set
25# CONFIG_SYS_FLASH_USE_BUFFER_WRITE is not set
26# CONFIG_SYS_FLASH_CFI is not set
27# CONFIG_FLASH_CFI_DRIVER is not set
28# CONFIG_CMD_FLASH is not set
29# CONFIG_CMD_IMLS is not set
30# CONFIG_MTD_NOR_FLASH is not set
31# CONFIG_MTD_DEVICE is not set
32# CONFIG_SYS_FLASH_PROTECTION is not set
33# CONFIG_SPI_FLASH_SST is not set
34# CONFIG_XILINX_EMACLITE is not set
35# CONFIG_PHY_VITESSE is not set
36# CONFIG_CMD_EXT2 is not set
37# CONFIG_CMD_EXT4 is not set
38# CONFIG_CMD_EXT4_WRITE is not set
39# CONFIG_CMD_FAT is not set
40# CONFIG_DOS_PARTITION is not set
41# CONFIG_FAT_WRITE is not set
42CONFIG_DM=y
43CONFIG_SYS_MALLOC_F=y
44CONFIG_XILINX_UARTLITE=y
45CONFIG_XILINX_AXIEMAC=y
46CONFIG_PHY_XILINX=y
47CONFIG_PHY_TI=y
48CONFIG_NET=y
49CONFIG_PHY_GIGE=y
50CONFIG_NETDEVICES=y
51CONFIG_CMD_NET=y
52CONFIG_DM_ETH=y
53CONFIG_CMD_PING=y
54CONFIG_CMD_DHCP=y
55CONFIG_PHYLIB=y
56CONFIG_CMD_TFTPPUT=y
57CONFIG_CMD_NFS=y
58CONFIG_CMD_MII=y
59CONFIG_PHY_MARVELL=y
60CONFIG_PHY_REALTEK=y
61CONFIG_PHY_NATSEMI=y
62CONFIG_XILINX_SPI=y
63CONFIG_CMD_SPI=y
64CONFIG_CMD_SF=y
65CONFIG_SPI_FLASH=y
66CONFIG_SPI_FLASH_BAR=y
67CONFIG_DM_SPI_FLASH=y
68CONFIG_DM_SPI=y
69CONFIG_SPI_FLASH_SPANSION=y
70CONFIG_SPI_FLASH_STMICRO=y
71CONFIG_SPI_FLASH_WINBOND=y
72CONFIG_SPI_FLASH_MACRONIX=y
73CONFIG_SPI=y
74CONFIG_SPI_FLASH_ISSI=y
75# CONFIG_BOOTARGS is not set
76# CONFIG_USE_BOOTARGS is not set
77# CONFIG_SPL is not set
78# CONFIG_I2C_EEPROM is not set
79# CONFIG_CMD_EEPROM is not set
80# CONFIG_SYS_I2C_EEPROM_ADDR is not set
81# CONFIG_SYS_I2C_EEPROM_ADDR_OVERFLOW is not set
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2022.2.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2022.2.inc
index 6415861d..f9b8f52b 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2022.2.inc
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2022.2.inc
@@ -1,4 +1,4 @@
1UBOOT_VERSION = "v2021.01" 1UBOOT_VERSION = "v2022.01"
2 2
3UBRANCH ?= "xlnx_rebase_v2022.01" 3UBRANCH ?= "xlnx_rebase_v2022.01"
4 4