diff options
author | Sivaprasad Addepalli <sivaprasad.addepalli@xilinx.com> | 2023-07-19 13:13:30 +0530 |
---|---|---|
committer | Siva Addepalli <sivaprasad.addepalli@xilinx.com> | 2023-07-19 15:27:13 +0530 |
commit | 95a9c3f754aa1d188ec0a7ba8c7e6c770d1d2c31 (patch) | |
tree | 7330c6ace7ef6ac3c00764582249bd62ddf9c3d4 | |
parent | ed8f6491c1e5ce1d1a08f559023c05431f990b9f (diff) | |
download | meta-xilinx-95a9c3f754aa1d188ec0a7ba8c7e6c770d1d2c31.tar.gz |
embeddedsw : Updated SRCREV for 2023.2_3455
emacps: Fix cfg ptr error
xiltimer: Add proper checks
freertos10_xilinx: Fix SDT flow for microblaze
driver: trngpsv: added SDT support
sw_services: xilmailbox: Add example support in SDT flow
xilpm: versal_net: Save and Restore XPm_Reqm
xilflash: Fix code formatting issues with checkpatch
xliflash: Add AMD copyright information
xilflash: Add support for system device-tree flow for example
xilflash: Update lib to support for system device-tree flow
lib: sw_apps: freertos_lwip_udp_perf_client: Add SDT code deviations
lib: sw_apps: freertos_lwip_udp_perf_client: Add SDT metadata files
lib: sw_apps: freertos_lwip_udp_perf_server: Add SDT flow deviations
lib: sw_apps: freertos_lwip_udp_perf_server: Add SDT flow metadata files
lib: sw_apps: freertos_lwip_tcp_perf_client: Add SDT deviations
lib: sw_apps: freertos_lwip_tcp_perf_client: Add SDT metada files
lib: sw_apps: freertos_lwip_tcp_perf_server: Add SDT deviations
lib: sw_apps: freertos_lwip_tcp_server: Add SDT metadata
lib: sw_apps: freertos_lwip_echo_server: Add SDT code deviations
lib: sw_apps: freertos_lwip_echo_server: Add SDT Flow.
lib: sw_apps: lwip_udp_server_client: Add SDT deviations
lib: sw_apps: lwip_udp_perf_client: Add SDT metadata files
lib: sw_apps: lwip_udp_perf_server: Add SDT flow deviations
lib: sw_apps: lwip_udp_perf_server: Add SDT metada files
lib: sw_apps: lwip_tcp_perf_client: Add SDT flow deviations
lib: sw_apps: lwip_tcp_perf_client: Add SDT metadata files
lib: sw_apps: lwip_tcp_perf_server: Add SDT deviations
lib: sw_apps: lwip_tcp_perf_server: Add SDT metada files
lib: sw_apps: lwip_echo_server: Add SDT flow deviations
lib: sw_apps: lwip_echo_server: Add metadata for SDT flow
sw_apps: srec_spi_bootloader: Fix style issues
sw_apps:srec_spi_bootloader: Support SDT flow
trafgen: Fix the disable interrupt
uartns550: Add outbyte and inbyte in SDT flow
axicdma: Add support for peripheral test in SDT flow
cmake: Fix Microblaze BSP failure on windows
cmake: Fix microblaze based toolchain files for windows
uartlite: Add outbyte and inbyte in SDT flow
sdps: Fix code format issues
sdps: Add support for system device-tree flow for examples
sdps: Add support for system device-tree flow
xilffs: Fix code format issues
xilffs: Add support for system device-tree flow for examples
xilffs: Add support for system device-tree flow
scripts: pyesw: library_utils: Update the gen_lib_metadata() API to generate pm_cfg_obj.c for xilpm library
scripts: pyesw: library_utils: Fix race condition in populating the param value
scripts: pyesw: create_example: Fix compilation errors on windows
scripts: pyesw: config_bsp: Fix set_repo_path for windows
scripts: pyesw: Update link libraries based on the available libraries in the bsp
rfdc: Updated examples to SDT flow
SDT: Update libmetal driver yamls
hello_world/empty_app: Correct the processor names in the application yamls
scugic: Adding a SDT check to not rely on one of the xparameter definition
BSP: cortexr5: Fix SDT flow for CortexR5
BSP: cortexr5: Support SDT flow for CortexR52 BSP
standalone: cortexr5: Moving the versal r5 specific files to CortexR5 folder
standalone: CMakeLists/headers: Adding versal-net specific checks and R52 specific files
linker_files: Adding support for versal-net specific linker files
standalone: yaml: Adding versal-net specific entries in standalone yaml files
cmake: toolchainfiles: Adding new toolchainfiles for versal-net
rfdc: Fix issues with SDT
sw_services:xilsecure:Loading partial PDI when SHA core is busy
sw_services:xilsecure:Throw an error when AES/SHA is already in use
tmrctr: Update signatures of examples being used in peripheral tests
BSP: intr: Fix style issues
tmrctr: Fix style issues
intc: Fix style issues
tmrctr: Port examples to SDT flow
intc: Port examples to SDT flow
intc: Add support for SDT flow
BSP: Fix xinterrupt_wrap APIs for AXI INTC
xxvethernet: Fix code formatting in examples
xxvethernet: examples: Add support for system device-tree flow
drivers: xxvethernet: Add device-tree flow support for xxvethernet
axienet: Add support for system device-tree
axienet: Update axienet driver to support SDT and non-SDT flows
axienet: Update tcl script to support opensource macros
axienet: Update driver version to 5.16
mcdma: Update driver to support SDT flow
emaclite: examples: Update code formatting
emaclite: examples: Add system device-tree flow support
drivers: emaclite: Add support for device-tree flow
iicps: Fix code formatting issues with checkpatch
iicps: Add support for system device-tree flow for iicps examples
iicps: Add support for system device-tree flow
spi: Fix code formatting issues with checkpatch
spi: Add support for system device-tree flow for examples
spi: Add support for system device-tree flow
mutex: Add support for peripheral tests in SDT flow
xdmapcie: Add examples in YAML for SDT flow
pciepsu: Add properties to support SDT flow
Signed-off-by: Siva Addepalli <sivaprasad.addepalli@xilinx.com>
-rw-r--r-- | meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass index 8fbda388..fa6079d5 100644 --- a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass +++ b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass | |||
@@ -8,7 +8,7 @@ ESW_BRANCH[2023.2] = "master-next" | |||
8 | BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}" | 8 | BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}" |
9 | 9 | ||
10 | ESW_REV[2023.1] = "e24fe92b5517ee447e560790e798cad792f53bab" | 10 | ESW_REV[2023.1] = "e24fe92b5517ee447e560790e798cad792f53bab" |
11 | ESW_REV[2023.2] = "c0718491347a83ba40dbc96dfdb2130dd8743363" | 11 | ESW_REV[2023.2] = "90843c3dbbd679da4179da21d94b5ac8930747bf" |
12 | SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or '${AUTOREV}'}" | 12 | SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or '${AUTOREV}'}" |
13 | 13 | ||
14 | EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}" | 14 | EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}" |