summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-07-18 16:38:25 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-08-20 00:35:47 +1000
commit87773044869928c70cb41a750849202e9c6a12c2 (patch)
treeebd4b64711f4aa8caf16e07b7ef15fd83ff57bba
parent038f1b148372baab51a5b41017271e69030b7bbf (diff)
downloadmeta-xilinx-87773044869928c70cb41a750849202e9c6a12c2.tar.gz
binutils: Remove MicroBlaze specific patch
This patch is no longer required, the behaviour has been resolved. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-microblaze/binutils/binutils%.bbappend7
-rw-r--r--recipes-microblaze/binutils/files/upstream-change-to-garbage-collection-s.patch38
2 files changed, 0 insertions, 45 deletions
diff --git a/recipes-microblaze/binutils/binutils%.bbappend b/recipes-microblaze/binutils/binutils%.bbappend
deleted file mode 100644
index 2a53ab74..00000000
--- a/recipes-microblaze/binutils/binutils%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
1
2# Add MicroBlaze Patches
3FILESEXTRAPATHS_append := "${THISDIR}/files:"
4SRC_URI_append_microblaze = " \
5 file://upstream-change-to-garbage-collection-s.patch \
6 "
7
diff --git a/recipes-microblaze/binutils/files/upstream-change-to-garbage-collection-s.patch b/recipes-microblaze/binutils/files/upstream-change-to-garbage-collection-s.patch
deleted file mode 100644
index aa571d45..00000000
--- a/recipes-microblaze/binutils/files/upstream-change-to-garbage-collection-s.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From: David Holsgrove <david.holsgrove@xilinx.com>
2Date: Wed, 27 Feb 2013 13:56:11 +1000
3Subject: upstream change to garbage collection sweep causes mb regression
4
5Upstream change for PR13177 now clears the def_regular during gc_sweep of a
6section. (All other archs in binutils/bfd/elf32-*.c received an update
7to a warning about unresolvable relocations - this warning is not present
8in binutils/bfd/elf32-microblaze.c, but this warning check would not
9prevent the error being seen)
10
11The visible issue with this change is when running a c++ application
12in Petalinux which links libstdc++.so for exception handling it segfaults
13on execution.
14
15This does not occur if static linking libstdc++.a, so its during the
16relocations for a shared lib with garbage collection this occurs
17
18Signed-off-by: David Holsgrove <david.holsgrove@xilinx.com>
19Upstream-Status: Pending
20---
21 bfd/elflink.c | 1 -
22 1 file changed, 1 deletion(-)
23
24diff --git a/bfd/elflink.c b/bfd/elflink.c
25index 99b7ca1..415d714 100644
26--- a/bfd/elflink.c
27+++ b/bfd/elflink.c
28@@ -11909,7 +11909,6 @@ elf_gc_sweep_symbol (struct elf_link_hash_entry *h, void *data)
29
30 inf = (struct elf_gc_sweep_symbol_info *) data;
31 (*inf->hide_symbol) (inf->info, h, TRUE);
32- h->def_regular = 0;
33 h->ref_regular = 0;
34 h->ref_regular_nonweak = 0;
35 }
36--
371.8.5.1
38