summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-11-21 13:11:50 -0800
committerMark Hatle <mark.hatle@amd.com>2022-11-24 07:00:36 -0800
commit87054357b1c6a8c2adbbf01fb037c5e90beb98df (patch)
tree35e4837b884eff123dc80c454b92715dbd7f9df8
parentdb9994784a14ffd353fd0d4218a5a05fc3976b0d (diff)
downloadmeta-xilinx-87054357b1c6a8c2adbbf01fb037c5e90beb98df.tar.gz
qemu-xilinx-helper-native: Remove, replace with standard upstream version
qemu-system-helper contains support for general system items, there is no reason for us to provide our own version. We can then add a dependency for the specific xilinx multiarch component as needed to the system-native versions. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/classes/qemuboot-xilinx.bbclass10
-rw-r--r--meta-xilinx-core/conf/machine/include/machine-xilinx-qemu.inc1
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb13
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb1
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb1
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.1.bb1
6 files changed, 3 insertions, 24 deletions
diff --git a/meta-xilinx-core/classes/qemuboot-xilinx.bbclass b/meta-xilinx-core/classes/qemuboot-xilinx.bbclass
index 58ade1b9..3835591d 100644
--- a/meta-xilinx-core/classes/qemuboot-xilinx.bbclass
+++ b/meta-xilinx-core/classes/qemuboot-xilinx.bbclass
@@ -136,13 +136,3 @@ def qemu_zynqmp_unhalt(data, multiarch):
136 if multiarch: 136 if multiarch:
137 return "-global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true" 137 return "-global xlnx,zynqmp-boot.cpu-num=0 -global xlnx,zynqmp-boot.use-pmufw=true"
138 return "-device loader,addr=0xfd1a0104,data=0x8000000e,data-len=4 -device loader,addr=0xfd1a0104,data=0x8000000e,data-len=4" 138 return "-device loader,addr=0xfd1a0104,data=0x8000000e,data-len=4 -device loader,addr=0xfd1a0104,data=0x8000000e,data-len=4"
139
140# rewrite the qemuboot with the custom sysroot bindir
141python do_write_qemuboot_conf:append() {
142 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'), 'qemu-xilinx-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
143 cf.set('config_bsp', 'STAGING_BINDIR_NATIVE', '%s' % val)
144
145 # write out the updated version from this append
146 with open(qemuboot, 'w') as f:
147 cf.write(f)
148}
diff --git a/meta-xilinx-core/conf/machine/include/machine-xilinx-qemu.inc b/meta-xilinx-core/conf/machine/include/machine-xilinx-qemu.inc
index 7b953975..2f2c20e3 100644
--- a/meta-xilinx-core/conf/machine/include/machine-xilinx-qemu.inc
+++ b/meta-xilinx-core/conf/machine/include/machine-xilinx-qemu.inc
@@ -1,7 +1,6 @@
1# This include is used to setup default QEMU and qemuboot config for meta-xilinx 1# This include is used to setup default QEMU and qemuboot config for meta-xilinx
2# machines. 2# machines.
3 3
4PREFERRED_PROVIDER_qemu-helper-native = "qemu-xilinx-helper-native"
5PREFERRED_PROVIDER_qemu = "qemu-xilinx" 4PREFERRED_PROVIDER_qemu = "qemu-xilinx"
6PREFERRED_PROVIDER_qemu-native = "qemu-xilinx-native" 5PREFERRED_PROVIDER_qemu-native = "qemu-xilinx-native"
7PREFERRED_PROVIDER_qemu-system-native = "qemu-xilinx-system-native" 6PREFERRED_PROVIDER_qemu-system-native = "qemu-xilinx-system-native"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
deleted file mode 100644
index dd47f7a7..00000000
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1FILESEXTRAPATHS:prepend := "${COREBASE}/meta/recipes-devtools/qemu/qemu-helper:"
2
3require ${COREBASE}/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
4
5# provide it, to replace the existing recipe
6PROVIDES = "qemu-helper-native"
7
8# replace qemu with qemu-xilinx
9DEPENDS:remove = "qemu-system-native"
10DEPENDS:append = " qemu-xilinx-system-native qemu-xilinx-multiarch-helper-native"
11
12RDEPENDS:${PN}:remove = "qemu-system-native"
13RDEPENDS:${PN}:append = " qemu-xilinx-system-native"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
index 9a420021..d67b401d 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
@@ -10,6 +10,7 @@ PACKAGECONFIG ??= "fdt alsa kvm pie slirp"
10PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" 10PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
11 11
12DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native" 12DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
13DEPENDS += "qemu-xilinx-multiarch-helper-native"
13 14
14do_install:append() { 15do_install:append() {
15 # The following is also installed by qemu-native 16 # The following is also installed by qemu-native
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
index 3a8eadc4..8cef3db2 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
@@ -10,6 +10,7 @@ PACKAGECONFIG ??= "fdt alsa kvm pie slirp"
10PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" 10PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
11 11
12DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native" 12DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
13DEPENDS += "qemu-xilinx-multiarch-helper-native"
13 14
14do_install:append() { 15do_install:append() {
15 # The following is also installed by qemu-native 16 # The following is also installed by qemu-native
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.1.bb
index a0b889b7..1fb51cdd 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.1.bb
@@ -11,6 +11,7 @@ PACKAGECONFIG ??= "fdt alsa kvm pie slirp"
11PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" 11PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
12 12
13DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native" 13DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
14DEPENDS += "qemu-xilinx-multiarch-helper-native"
14 15
15do_install:append() { 16do_install:append() {
16 # The following is also installed by qemu-native 17 # The following is also installed by qemu-native