summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-07-22 09:29:13 -0700
committerMark Hatle <mark.hatle@amd.com>2022-07-23 14:44:50 -0700
commit85c006c70fa74074b7711d77f5941d890ced1de8 (patch)
treef1e90ddb8694d72d420c76bd3cab84b21364bc0f
parent2e4c8c6676dba37dc2623f1c1826e4af790c891b (diff)
downloadmeta-xilinx-85c006c70fa74074b7711d77f5941d890ced1de8.tar.gz
libdfx_1.0.bb: Manually specify that 'libdfx' package is being replaced
The commit a64ff0bf015adcefbe691a94ac3e8ecf1a2ba911 updated the upstream source to include correct soname/soversion. Packaging was then modified to follow this example. The end result was that 'libdfx' was replaced by the automatic "libdfx1.0" package. This could result in: Error: Transaction test error: file /usr/lib/libdfx.so from install of libdfx-dev-1.0-r0.1.cortexa72_cortexa53 conflicts with file from package libdfx-1.0-r0.0.cortexa72_cortexa53 The cause was that libdfx wasn't upgraded when libdfx-dev was being installed. To resolve this we use RREPLACES, may look strange but this will instruct the system that "libdfx" is to be replaced by the dynamically generated package based on the soname. Signed-off-by: Mark Hatle <mark.hatle@amd.com> (cherry picked from commit 4dd53057341c8a88a0e89f623330f4f9a1915561) Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
index 83ae7722..1c43f49d 100644
--- a/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
+++ b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
@@ -18,3 +18,6 @@ S = "${WORKDIR}/git"
18 18
19inherit cmake 19inherit cmake
20 20
21# Due to an update where the soname/version was defined, we need to use an RREPLACES
22# so updates will work properly.
23RREPLACES:${PN} = "libdfx"