summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-01-24 17:24:00 -0800
committerMark Hatle <mark.hatle@amd.com>2023-04-10 09:03:22 -0700
commit74c1cc2ba157678b78a8ef35ac679036d7dff370 (patch)
treeae4725cd8bbe1360afbdf225d4253f655b9f4394
parent1c4f451ee4ec40a872c23bc5a837e66709b4e01f (diff)
downloadmeta-xilinx-74c1cc2ba157678b78a8ef35ac679036d7dff370.tar.gz
qemu-xilinx: Add Yocto Project upstream patches
Yocto Project upstream patches resolve integration issues, and resolve various CVEs. Include these into the qemu-xilinx recipe. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/files/0010-configure-Add-pkg-config-handling-for-libgcrypt.patch29
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-7.1.inc20
2 files changed, 19 insertions, 30 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/files/0010-configure-Add-pkg-config-handling-for-libgcrypt.patch b/meta-xilinx-core/recipes-devtools/qemu/files/0010-configure-Add-pkg-config-handling-for-libgcrypt.patch
deleted file mode 100644
index 4298964d..00000000
--- a/meta-xilinx-core/recipes-devtools/qemu/files/0010-configure-Add-pkg-config-handling-for-libgcrypt.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From b51e6dd833172954c718bd600d846540eeb07220 Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Wed, 28 Aug 2019 19:56:28 +0800
4Subject: [PATCH] configure: Add pkg-config handling for libgcrypt
5
6libgcrypt may also be controlled by pkg-config, this patch adds pkg-config
7handling for libgcrypt.
8
9Upstream-Status: Denied [https://lists.nongnu.org/archive/html/qemu-devel/2019-08/msg06333.html]
10
11Signed-off-by: He Zhe <zhe.he@windriver.com>
12
13---
14 meson.build | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/meson.build b/meson.build
18index b3e7ec0e9..4cbe715b7 100644
19--- a/meson.build
20+++ b/meson.build
21@@ -874,7 +874,7 @@ endif
22 if not gnutls_crypto.found()
23 if (not get_option('gcrypt').auto() or have_system) and not get_option('nettle').enabled()
24 gcrypt = dependency('libgcrypt', version: '>=1.8',
25- method: 'config-tool',
26+ method: 'pkg-config',
27 required: get_option('gcrypt'),
28 kwargs: static_kwargs)
29 # Debian has removed -lgpg-error from libgcrypt-config
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-7.1.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-7.1.inc
index 595b988d..b65a1682 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-7.1.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-7.1.inc
@@ -18,7 +18,25 @@ REPO ?= "gitsm://github.com/Xilinx/qemu.git;protocol=https"
18BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" 18BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
19SRC_URI = "${REPO};${BRANCHARG}" 19SRC_URI = "${REPO};${BRANCHARG}"
20 20
21SRC_URI:append = " file://0010-configure-Add-pkg-config-handling-for-libgcrypt.patch" 21FILESEXTRAPATHS:append := ":${COREBASE}/meta/recipes-devtools/qemu/qemu"
22
23SRC_URI += "\
24 file://powerpc_rom.bin \
25 file://run-ptest \
26 file://0001-qemu-Add-addition-environment-space-to-boot-loader-q.patch \
27 file://0002-chardev-connect-socket-to-a-spawned-command.patch \
28 file://0003-apic-fixup-fallthrough-to-PIC.patch \
29 file://0004-configure-Add-pkg-config-handling-for-libgcrypt.patch \
30 file://0005-qemu-Do-not-include-file-if-not-exists.patch \
31 file://0006-qemu-Add-some-user-space-mmap-tweaks-to-address-musl.patch \
32 file://0007-qemu-Determinism-fixes.patch \
33 file://0008-tests-meson.build-use-relative-path-to-refer-to-file.patch \
34 file://0009-Define-MAP_SYNC-and-MAP_SHARED_VALIDATE-on-needed-li.patch \
35 file://0010-hw-pvrdma-Protect-against-buggy-or-malicious-guest-d.patch \
36 file://0001-net-tulip-Restrict-DMA-engine-to-memories.patch \
37 file://arm-cpreg-fix.patch \
38 file://CVE-2022-3165.patch \
39 "
22 40
23S = "${WORKDIR}/git" 41S = "${WORKDIR}/git"
24 42