summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-02-27 12:47:34 -0700
committerMark Hatle <mark.hatle@amd.com>2024-02-27 12:47:48 -0700
commit65a8fd1b23de37d8fc336dba51124390a57fa832 (patch)
tree1b78e4077cc8c820adf9e12beea37cf08fb878d9
parente54a296f64f649f76457970f98d70dc7d09e13ca (diff)
downloadmeta-xilinx-65a8fd1b23de37d8fc336dba51124390a57fa832.tar.gz
mesa: Rebase xlnx dri patch
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch b/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch
index e52ecb6a..f77f1939 100644
--- a/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch
+++ b/meta-xilinx-core/recipes-graphics/mesa/files/0001-DRI_Add_xlnx_dri.patch
@@ -6,26 +6,26 @@ Upstream-Status: Pending
6 6
7Signed-off-by: Mark Hatle <mark.hatle@amd.com> 7Signed-off-by: Mark Hatle <mark.hatle@amd.com>
8 8
9Index: mesa-23.3.3/src/gallium/targets/dri/meson.build 9Index: mesa-24.0.1/src/gallium/targets/dri/meson.build
10=================================================================== 10===================================================================
11--- mesa-23.3.3.orig/src/gallium/targets/dri/meson.build 11--- mesa-24.0.1.orig/src/gallium/targets/dri/meson.build
12+++ mesa-23.3.3/src/gallium/targets/dri/meson.build 12+++ mesa-24.0.1/src/gallium/targets/dri/meson.build
13@@ -93,6 +93,7 @@ foreach d : [[with_gallium_kmsro, [ 13@@ -101,6 +101,7 @@ foreach d : [[with_gallium_kmsro, [
14 'st7735r_dri.so',
15 'stm_dri.so', 14 'stm_dri.so',
16 'sun4i-drm_dri.so', 15 'sun4i-drm_dri.so',
16 'udl_dri.so',
17+ 'xlnx_dri.so', 17+ 'xlnx_dri.so',
18 ]], 18 ]],
19 [with_gallium_radeonsi, 'radeonsi_dri.so'], 19 [with_gallium_radeonsi, 'radeonsi_dri.so'],
20 [with_gallium_nouveau, 'nouveau_dri.so'], 20 [with_gallium_nouveau, 'nouveau_dri.so'],
21Index: mesa-23.3.3/src/gallium/targets/dri/target.c 21Index: mesa-24.0.1/src/gallium/targets/dri/target.c
22=================================================================== 22===================================================================
23--- mesa-23.3.3.orig/src/gallium/targets/dri/target.c 23--- mesa-24.0.1.orig/src/gallium/targets/dri/target.c
24+++ mesa-23.3.3/src/gallium/targets/dri/target.c 24+++ mesa-24.0.1/src/gallium/targets/dri/target.c
25@@ -123,6 +123,7 @@ DEFINE_LOADER_DRM_ENTRYPOINT(st7586) 25@@ -129,6 +129,7 @@ DEFINE_LOADER_DRM_ENTRYPOINT(sti)
26 DEFINE_LOADER_DRM_ENTRYPOINT(st7735r)
27 DEFINE_LOADER_DRM_ENTRYPOINT(stm) 26 DEFINE_LOADER_DRM_ENTRYPOINT(stm)
28 DEFINE_LOADER_DRM_ENTRYPOINT(sun4i_drm) 27 DEFINE_LOADER_DRM_ENTRYPOINT(sun4i_drm)
28 DEFINE_LOADER_DRM_ENTRYPOINT(udl)
29+DEFINE_LOADER_DRM_ENTRYPOINT(xlnx) 29+DEFINE_LOADER_DRM_ENTRYPOINT(xlnx)
30 #endif 30 #endif
31 31