summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-10-25 12:47:08 -0600
committerMark Hatle <mark.hatle@amd.com>2023-10-25 12:47:15 -0600
commit5a0ce8508d9f15c6289d9461c9e4d6ce25c6a766 (patch)
treec5db37c3c65f0e140c49d28c0c70844b6338f2e7
parent7d7a919f5f3ac950b976df98f27b803d14e0fd30 (diff)
downloadmeta-xilinx-5a0ce8508d9f15c6289d9461c9e4d6ce25c6a766.tar.gz
qemu-xilinx: Fix 2023.2 integration
Duplicate what was done in 2023.1 to allow qemu-xilinx to build. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-2023.2.inc2
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2023.2.bb11
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.2.bb11
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.2.bb11
4 files changed, 35 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-2023.2.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-2023.2.inc
index db6e1528..9831e1a5 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-2023.2.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-2023.2.inc
@@ -1,3 +1,5 @@
1XILINX_QEMU_VERSION = "v7.1.0" 1XILINX_QEMU_VERSION = "v7.1.0"
2BRANCH = "xlnx_rel_v2023.2" 2BRANCH = "xlnx_rel_v2023.2"
3SRCREV = "23b643ba1683a47ef49447a45643fe2172d6f8ca" 3SRCREV = "23b643ba1683a47ef49447a45643fe2172d6f8ca"
4
5PACKAGECONFIG[debuginfo] = ""
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2023.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2023.2.bb
index ccfa9956..6cc6e826 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2023.2.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2023.2.bb
@@ -4,6 +4,17 @@ require qemu-native-alt.inc
4 4
5BPN = "qemu-xilinx" 5BPN = "qemu-xilinx"
6 6
7# Latest poky has changed the defaults, restore them to something compatible
8# with this QEMU. When we update to QEMU 8.x this won't be necessary.
9EXTRA_OECONF:remove = "--disable-download"
10EXTRA_OECONF:remove = "--disable-docs"
11
12EXTRA_OECONF:append = "\
13 --with-git=/bin/false \
14 --with-git-submodules=ignore \
15 --meson=meson \
16"
17
7EXTRA_OECONF:append = " --target-list=${@get_qemu_usermode_target_list(d)} --disable-tools --disable-blobs --disable-guest-agent" 18EXTRA_OECONF:append = " --target-list=${@get_qemu_usermode_target_list(d)} --disable-tools --disable-blobs --disable-guest-agent"
8 19
9PACKAGECONFIG ??= "pie" 20PACKAGECONFIG ??= "pie"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.2.bb
index 21208f72..3de49299 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.2.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2023.2.bb
@@ -4,6 +4,17 @@ require qemu-xilinx-native-7.1.inc
4 4
5PROVIDES = "qemu-system-native" 5PROVIDES = "qemu-system-native"
6 6
7# Latest poky has changed the defaults, restore them to something compatible
8# with this QEMU. When we update to QEMU 8.x this won't be necessary.
9EXTRA_OECONF:remove = "--disable-download"
10EXTRA_OECONF:remove = "--disable-docs"
11
12EXTRA_OECONF:append = "\
13 --with-git=/bin/false \
14 --with-git-submodules=ignore \
15 --meson=meson \
16"
17
7EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" 18EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
8 19
9PACKAGECONFIG ??= "fdt alsa kvm gcrypt pie slirp" 20PACKAGECONFIG ??= "fdt alsa kvm gcrypt pie slirp"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.2.bb
index e79df9d7..c0be61d3 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.2.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.2.bb
@@ -17,6 +17,17 @@ RDEPENDS:${PN}:class-target += "bash"
17PROVIDES:class-nativesdk = "nativesdk-qemu" 17PROVIDES:class-nativesdk = "nativesdk-qemu"
18RPROVIDES:${PN}:class-nativesdk = "nativesdk-qemu" 18RPROVIDES:${PN}:class-nativesdk = "nativesdk-qemu"
19 19
20# Latest poky has changed the defaults, restore them to something compatible
21# with this QEMU. When we update to QEMU 8.x this won't be necessary.
22EXTRA_OECONF:remove = "--disable-download"
23EXTRA_OECONF:remove = "--disable-docs"
24
25EXTRA_OECONF:append = "\
26 --with-git=/bin/false \
27 --with-git-submodules=ignore \
28 --meson=meson \
29"
30
20EXTRA_OECONF:append:class-target = " --target-list=${@get_qemu_target_list(d)}" 31EXTRA_OECONF:append:class-target = " --target-list=${@get_qemu_target_list(d)}"
21EXTRA_OECONF:append:class-nativesdk = " --target-list=${@get_qemu_target_list(d)}" 32EXTRA_OECONF:append:class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
22EXTRA_OECONF:append:class-target:mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}" 33EXTRA_OECONF:append:class-target:mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"