summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2013-05-08 13:40:31 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2013-05-08 13:40:31 +1000
commit4c669faa887c1300551ac5ff34d460839081a0cb (patch)
tree8ab15aae9c13561f5a7974dd68fcb8be07ab1a11
parentb769bf5d888eaf5b45d22cc2b119e67d786fc702 (diff)
downloadmeta-xilinx-4c669faa887c1300551ac5ff34d460839081a0cb.tar.gz
u-boot-xlnx: Add microblaze specific configuration setup
* When the machine being built is microblaze, copy config.mk and xparameters.h into board/xilinx/microblaze-generic * Fixed newlines in file Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-extra.inc38
1 files changed, 25 insertions, 13 deletions
diff --git a/recipes-bsp/u-boot/u-boot-extra.inc b/recipes-bsp/u-boot/u-boot-extra.inc
index aa7e6149..f07284a5 100644
--- a/recipes-bsp/u-boot/u-boot-extra.inc
+++ b/recipes-bsp/u-boot/u-boot-extra.inc
@@ -1,13 +1,25 @@
1 1
2# Also deploy u-boot elf file with same file format as bin file 2# Also deploy u-boot elf file with same file format as bin file
3SRC_ELF ?= "u-boot" 3SRC_ELF ?= "u-boot"
4DEST_ELF ?= "u-boot-${MACHINE}-${PV}-${PR}.elf" 4DEST_ELF ?= "u-boot-${MACHINE}-${PV}-${PR}.elf"
5ELF_SYMLINK ?= "u-boot-${MACHINE}.elf" 5ELF_SYMLINK ?= "u-boot-${MACHINE}.elf"
6do_deploy_append() { 6do_deploy_append() {
7 install ${S}/${SRC_ELF} ${DEPLOYDIR}/${DEST_ELF} 7 install ${S}/${SRC_ELF} ${DEPLOYDIR}/${DEST_ELF}
8 8
9 cd ${DEPLOYDIR} 9 cd ${DEPLOYDIR}
10 rm -f ${SRC_ELF} ${ELF_SYMLINK} 10 rm -f ${SRC_ELF} ${ELF_SYMLINK}
11 ln -sf ${DEST_ELF} ${ELF_SYMLINK} 11 ln -sf ${DEST_ELF} ${ELF_SYMLINK}
12 ln -sf ${DEST_ELF} ${SRC_ELF}.elf 12 ln -sf ${DEST_ELF} ${SRC_ELF}.elf
13} \ No newline at end of file 13}
14
15# Install the MicroBlaze System configuration into the board configuration
16do_configure_prepend () {
17 if [ "${SOC_FAMILY}" = "microblaze" ]; then
18 if [ -e ${WORKDIR}/config.mk ]; then
19 cp ${WORKDIR}/config.mk ${S}/board/xilinx/microblaze-generic/
20 fi
21 if [ -e ${WORKDIR}/xparameters.h ]; then
22 cp ${WORKDIR}/xparameters.h ${S}/board/xilinx/microblaze-generic/
23 fi
24 fi
25}