summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-04-18 13:26:35 -0600
committerMark Hatle <mark.hatle@amd.com>2024-04-19 10:03:07 -0600
commit4afde2e340bd85cd56b1a429be6862b0ab116b5f (patch)
treebd29169f953ae47d51c187ba343214adef06994b
parentbc42ff18ab35854b7d92c5f1ae2dda8b311fa6f5 (diff)
downloadmeta-xilinx-4afde2e340bd85cd56b1a429be6862b0ab116b5f.tar.gz
meta-xilinx-standalone-experimental: embeddedsw: Fix integration
Fix plm and psm firwmare integration. The class EXPORT behavior has changed in Scarthgap, so sync up to the recent changes to ensure behavior is the same as the prior langdale based system. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend10
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend10
2 files changed, 16 insertions, 4 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
index cc6d757f..202764ac 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
index c4953ce7..96cd38cd 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {