summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-10-14 07:46:38 -0700
committerMark Hatle <mark.hatle@xilinx.com>2021-10-25 14:57:25 -0700
commit33f451ebae9b35a59e31bc3d17633f83bd2f2e94 (patch)
tree513c171a350815eed98f5205815bc2e7227ad3cd
parentb56b1562c129fd12b486fd6666315afd4644ce6a (diff)
downloadmeta-xilinx-33f451ebae9b35a59e31bc3d17633f83bd2f2e94.tar.gz
meta-xilinx-standalone: gcc-source bbappend changes
The regular (all version) bbappend will work with both gcc 10 and gcc 11. It only needs to tell the system it is compatible with baremetal builds. The special gcc-source_10 version works with the unique microblaze gcc only. This verifies, and configures the microblaze toolchain for the large multiconfig SDK build. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
-rw-r--r--meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_%.bbappend14
-rw-r--r--meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_10.%.bbappend13
2 files changed, 13 insertions, 14 deletions
diff --git a/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_%.bbappend b/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_%.bbappend
index f2c9051d..0d824324 100644
--- a/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_%.bbappend
+++ b/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_%.bbappend
@@ -1,15 +1 @@
1COMPATIBLE_HOST = "${HOST_SYS}" COMPATIBLE_HOST = "${HOST_SYS}"
2
3# Add MicroBlaze Patches (only when using MicroBlaze)
4FILESEXTRAPATHS:append:microblaze_xilinx-standalone := ":${THISDIR}/gcc-10"
5SRC_URI:append:microblaze_xilinx-standalone = " \
6 file://additional-microblaze-multilibs.patch \
7"
8
9CHECK_FOR_MICROBLAZE:microblaze = "1"
10
11python() {
12 if d.getVar('CHECK_FOR_MICROBLAZE') == '1':
13 if 'xilinx-microblaze' not in d.getVar('BBFILE_COLLECTIONS').split():
14 bb.fatal('You must include the meta-microblaze layer to build for this configuration.')
15}
diff --git a/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_10.%.bbappend b/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_10.%.bbappend
new file mode 100644
index 00000000..c0ffbe40
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-devtools/gcc/gcc-source_10.%.bbappend
@@ -0,0 +1,13 @@
1# Add MicroBlaze Patches (only when using MicroBlaze)
2FILESEXTRAPATHS:append:microblaze:xilinx-standalone := ":${THISDIR}/gcc-10"
3SRC_URI:append:microblaze:xilinx-standalone = " \
4 file://additional-microblaze-multilibs.patch \
5"
6
7CHECK_FOR_MICROBLAZE:microblaze = "1"
8
9python() {
10 if d.getVar('CHECK_FOR_MICROBLAZE') == '1':
11 if 'xilinx-microblaze' not in d.getVar('BBFILE_COLLECTIONS').split():
12 bb.fatal('You must include the meta-microblaze layer to build for this configuration.')
13}