summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2013-11-28 14:41:59 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2013-11-28 14:41:59 +1000
commit09b5d05924c95d027660f5bedad5fe3629dcf2e1 (patch)
tree78fbea340e58143b0f87511da2a25f5ca3c98fb7
parenta573551a42e2f4c8efa82db90f938b10e62a3971 (diff)
downloadmeta-xilinx-09b5d05924c95d027660f5bedad5fe3629dcf2e1.tar.gz
openssl: Add support to build MicroBlaze targets
Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rw-r--r--recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch26
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1e.bbappend3
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch b/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch
new file mode 100644
index 00000000..1723febb
--- /dev/null
+++ b/recipes-connectivity/openssl/files/Add-MicroBlaze-Support.patch
@@ -0,0 +1,26 @@
1From: Nathan Rossi <nathan.rossi@xilinx.com>
2Subject: [PATCH] Add MicroBlaze Support
3
4Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
5Upstream-Status: Not Submitted
6---
7 Configure | 4 ++++
8 1 files changed, 4 insertions(+), 0 deletions(-)
9
10diff --git a/Configure b/Configure
11index 0c54d19..edaae47 100755
12--- a/Configure
13+++ b/Configure
14@@ -467,6 +467,10 @@ my %table=(
15 "linux-mips64el","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
16 "linux-mipsel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
17
18+#### Linux on MicroBlaze
19+"linux-microblaze","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
20+"linux-microblazeel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
21+
22 # Android: linux-* but without -DTERMIO and pointers to headers and libs.
23 "android","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
24 "android-x86","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:".eval{my $asm=${x86_elf_asm};$asm=~s/:elf/:android/;$asm}.":dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
25--
261.7.1
diff --git a/recipes-connectivity/openssl/openssl_1.0.1e.bbappend b/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
new file mode 100644
index 00000000..5f4a80ba
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
@@ -0,0 +1,3 @@
1
2FILESEXTRAPATHS := "${THISDIR}/files"
3SRC_URI_append += "file://Add-MicroBlaze-Support.patch"