summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch_2.0.0.bb')
-rw-r--r--recipes-networking/openvswitch/openvswitch_2.0.0.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_2.0.0.bb b/recipes-networking/openvswitch/openvswitch_2.0.0.bb
index 15c4dcaf..01003082 100644
--- a/recipes-networking/openvswitch/openvswitch_2.0.0.bb
+++ b/recipes-networking/openvswitch/openvswitch_2.0.0.bb
@@ -14,6 +14,10 @@ RDEPENDS_${PN}-pki = "${PN}"
14RDEPENDS_${PN}-brcompat = "${PN} ${PN}-switch" 14RDEPENDS_${PN}-brcompat = "${PN} ${PN}-switch"
15RRECOMMENDS_${PN} += "kernel-module-openvswitch" 15RRECOMMENDS_${PN} += "kernel-module-openvswitch"
16 16
17RDEPENDS_${PN}-ptest += "python-logging python-syslog python-argparse python-io \
18 python-fcntl python-shell python-lang python-xml python-math \
19 python-datetime python-netclient python sed"
20
17# Some installers will fail because of an install order based on 21# Some installers will fail because of an install order based on
18# rdeps. E.g. ovs-pki calls sed in the postinstall. sed may be 22# rdeps. E.g. ovs-pki calls sed in the postinstall. sed may be
19# queued for install later. 23# queued for install later.
@@ -26,7 +30,9 @@ SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
26 file://openvswitch-controller-setup \ 30 file://openvswitch-controller-setup \
27 file://openvswitch-add-target-python-handling.patch \ 31 file://openvswitch-add-target-python-handling.patch \
28 file://openvswitch-add-target-perl-handling.patch \ 32 file://openvswitch-add-target-perl-handling.patch \
29 file://openvswitch-add-more-target-python-substitutions.patch \ 33 file://openvswitch-add-more-target-python-substitutions.patch \
34 file://openvswitch-add-ptest.patch \
35 file://run-ptest \
30 " 36 "
31 37
32SRC_URI[md5sum] = "7d7a58350e634e515e0fe43c64d64f44" 38SRC_URI[md5sum] = "7d7a58350e634e515e0fe43c64d64f44"
@@ -60,7 +66,13 @@ FILES_${PN}-switch = "${sysconfdir}/init.d/openvswitch-switch \
60FILES_${PN} += "${datadir}/ovsdbmonitor" 66FILES_${PN} += "${datadir}/ovsdbmonitor"
61FILES_${PN} += "/run" 67FILES_${PN} += "/run"
62 68
63inherit autotools update-rc.d 69inherit autotools update-rc.d ptest
70
71EXTRA_OEMAKE += "TEST_DEST=${D}${PTEST_PATH} TEST_ROOT=${PTEST_PATH}"
72
73do_install_ptest() {
74 oe_runmake test-install
75}
64 76
65INITSCRIPT_PACKAGES = "${PN}-switch ${PN}-controller" 77INITSCRIPT_PACKAGES = "${PN}-switch ${PN}-controller"
66INITSCRIPT_NAME_${PN}-switch = "openvswitch-switch" 78INITSCRIPT_NAME_${PN}-switch = "openvswitch-switch"