summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns/netns_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/netns/netns_git.bb')
-rw-r--r--recipes-networking/netns/netns_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 66f1f2a5..cd17e1a3 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -1,13 +1,13 @@
1HOMEPAGE = "https://github.com/jfrazelle/netns" 1HOMEPAGE = "https://github.com/jfrazelle/netns"
2SUMMARY = "Runc hook for setting up default bridge networking." 2SUMMARY = "Runc hook for setting up default bridge networking."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=48ef0979a2bcc3fae14ff30b8a7f5dbf" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=7bac31faf84a2d7e88972f562a3ebbe5"
5 5
6SRC_URI = "git://github.com/genuinetools/netns;branch=master;protocol=https \ 6SRC_URI = "git://github.com/genuinetools/netns;branch=master;protocol=https \
7 file://Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch \ 7 file://Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch \
8 " 8 "
9SRCREV = "9b103a19b917cc3762a33b7d78244b1d5e45ccfd" 9SRCREV = "00d5d07ab1c8afcf481ffa5958719943b6ecfde4"
10PV = "0.5.3" 10PV = "0.5.3+git${SRCPV}"
11GO_IMPORT = "import" 11GO_IMPORT = "import"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
@@ -29,8 +29,7 @@ do_compile() {
29 # they are not under the src directory. 29 # they are not under the src directory.
30 ln -sfn . "${S}/src/import/vendor/src" 30 ln -sfn . "${S}/src/import/vendor/src"
31 mkdir -p "${S}/src/import/vendor/src/github.com/genuinetools/netns" 31 mkdir -p "${S}/src/import/vendor/src/github.com/genuinetools/netns"
32 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/genuinetools/netns/ipallocator" 32
33 ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/genuinetools/netns/version"
34 export GOPATH="${S}/src/import/vendor" 33 export GOPATH="${S}/src/import/vendor"
35 34
36 # Pass the needed cflags/ldflags so that cgo 35 # Pass the needed cflags/ldflags so that cgo
@@ -40,6 +39,7 @@ do_compile() {
40 export LDFLAGS="" 39 export LDFLAGS=""
41 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 40 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
42 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 41 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
42 export GOFLAGS="-mod=vendor"
43 43
44 cd ${S}/src/import 44 cd ${S}/src/import
45 # Static builds work but are not recommended. See Makefile*cgo patch. 45 # Static builds work but are not recommended. See Makefile*cgo patch.