summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns/netns_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/netns/netns_git.bb')
-rw-r--r--recipes-networking/netns/netns_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index d35836ef..82a961bf 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -1,13 +1,13 @@
1HOMEPAGE = "https://github.com/jfrazelle/netns" 1HOMEPAGE = "https://github.com/jfrazelle/netns"
2SUMMARY = "Runc hook for setting up default bridge networking." 2SUMMARY = "Runc hook for setting up default bridge networking."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=48ef0979a2bcc3fae14ff30b8a7f5dbf"
5 5
6SRC_URI = "git://github.com/jessfraz/netns;branch=master \ 6SRC_URI = "git://github.com/genuinetools/netns;branch=master \
7 file://0001-Use-correct-go-cross-compiler.patch \ 7 file://0001-Allow-selection-of-go-compiler.patch \
8 " 8 "
9SRCREV = "74e23a0e5c4e7ac011aafcc4623586c196f1b3ef" 9SRCREV = "0da6ab0997707024debe68c91e940c9168041bf8"
10PV = "0.2.1" 10PV = "0.4.0"
11GO_IMPORT = "import" 11GO_IMPORT = "import"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
@@ -26,9 +26,9 @@ do_compile() {
26 # We also need to link in the ipallocator and version directories as 26 # We also need to link in the ipallocator and version directories as
27 # they are not under the src directory. 27 # they are not under the src directory.
28 ln -sfn . "${S}/src/import/vendor/src" 28 ln -sfn . "${S}/src/import/vendor/src"
29 mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/netns" 29 mkdir -p "${S}/src/import/vendor/src/github.com/genuinetools/netns"
30 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/jessfraz/netns/ipallocator" 30 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/genuinetools/netns/ipallocator"
31 ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/jessfraz/netns/version" 31 ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/genuinetools/netns/version"
32 export GOPATH="${S}/src/import/vendor" 32 export GOPATH="${S}/src/import/vendor"
33 33
34 # Pass the needed cflags/ldflags so that cgo 34 # Pass the needed cflags/ldflags so that cgo