summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch')
-rw-r--r--recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch b/recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch
new file mode 100644
index 00000000..74035283
--- /dev/null
+++ b/recipes-extended/xen/files/shim-don-t-let-build-modify-shim.config.patch
@@ -0,0 +1,47 @@
1From 8717e7417cebeae162fd61ea4cbdcdd422748f08 Mon Sep 17 00:00:00 2001
2From: Juergen Gross <jgross@suse.com>
3Date: Fri, 20 Apr 2018 17:47:55 +0200
4Subject: [PATCH] shim: don't let build modify shim.config
5
6Currently building the shim will modify shim.config in case some config
7option was added or modified in the hypervisor.
8
9Avoid that by copying shim.config to an intermediate file instead.
10
11Signed-off-by: Juergen Gross <jgross@suse.com>
12Reviewed-by: Jan Beulich <jbeulich@suse.com>
13Acked-by: Wei Liu <wei.liu2@citrix.com>
14---
15 tools/firmware/xen-dir/Makefile | 16 ++++++----------
16 1 file changed, 6 insertions(+), 10 deletions(-)
17
18diff --git a/tools/firmware/xen-dir/Makefile b/tools/firmware/xen-dir/Makefile
19index a7e69ae..84648c3 100644
20--- a/tools/firmware/xen-dir/Makefile
21+++ b/tools/firmware/xen-dir/Makefile
22@@ -41,16 +41,12 @@ linkfarm.stamp: $(DEP_DIRS) $(DEP_FILES) FORCE
23 $(D): linkfarm.stamp
24 $(MAKE) -C $(D)/xen distclean
25
26-.PHONY: shim-%config
27-shim-%config: $(D) FORCE
28- $(MAKE) -C $(D)/xen $*config \
29- XEN_CONFIG_EXPERT=y \
30- KCONFIG_CONFIG=$(CURDIR)/shim.config
31-
32-xen-shim: $(D) shim-olddefconfig
33- $(MAKE) -C $(D)/xen build \
34- XEN_CONFIG_EXPERT=y \
35- KCONFIG_CONFIG=$(CURDIR)/shim.config
36+$(D)/xen/.config: shim.config $(D)
37+ cp $< $@
38+ $(MAKE) -C $(@D) olddefconfig XEN_CONFIG_EXPERT=y
39+
40+xen-shim: $(D)/xen/.config
41+ $(MAKE) -C $(<D) build XEN_CONFIG_EXPERT=y
42 ln -sf $(D)/xen/xen $@
43 ln -sf $(D)/xen/xen-syms $@-syms
44
45--
462.7.4
47