summaryrefslogtreecommitdiffstats
path: root/recipes-extended/virt-manager/virt-manager_4.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/virt-manager/virt-manager_4.1.0.bb')
-rw-r--r--recipes-extended/virt-manager/virt-manager_4.1.0.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/virt-manager/virt-manager_4.1.0.bb b/recipes-extended/virt-manager/virt-manager_4.1.0.bb
new file mode 100644
index 00000000..a2395012
--- /dev/null
+++ b/recipes-extended/virt-manager/virt-manager_4.1.0.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = "virt-manager is a graphical tool for managing virtual machines via libvirt"
2HOMEPAGE = "https://virt-manager.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS += "python3-docutils-native"
6SRCREV = "6710ca6969b7d9c4e8344acd0fe3d50b24adc8ec"
7
8SRC_URI = " \
9 git://github.com/virt-manager/virt-manager;branch=main;protocol=https \
10 file://0001-setup.py-move-global-args-to-install-args.patch \
11"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= "gui"
16PACKAGECONFIG[gui] = ",--no-update-icon-cache --no-compile-schemas,python3-pygobject"
17
18inherit ${@bb.utils.contains('PACKAGECONFIG', 'gui', 'gtk-icon-cache', '', d)}
19inherit bash-completion gettext pkgconfig setuptools3_legacy
20
21PACKAGES += " \
22 ${PN}-common \
23 ${PN}-install \
24"
25
26RDEPENDS:${PN}-common += " \
27 libvirt-python \
28 libosinfo \
29"
30
31RDEPENDS:${PN} = "${PN}-common"
32RDEPENDS:${PN}-install = "${PN}-common"
33
34SETUPTOOLS_INSTALL_ARGS += "${PACKAGECONFIG_CONFARGS}"
35
36FILES:${PN} = " \
37 ${bindir}/virt-manager \
38 ${datadir}/icons/* \
39"
40
41FILES:${PN}-common = " \
42 ${libdir}/* \
43 ${libdir}/python3.10/* \
44 ${datadir}/applications \
45 ${datadir}/virt-manager \
46 ${datadir}/glib-2.0/* \
47 ${datadir}/metainfo/* \
48"
49
50FILES:${PN}-install = " \
51 ${bindir}/virt-clone \
52 ${bindir}/virt-install \
53 ${bindir}/virt-xml \
54"