summaryrefslogtreecommitdiffstats
path: root/recipes-extended/seabios/seabios_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/seabios/seabios_1.9.0.bb')
-rw-r--r--recipes-extended/seabios/seabios_1.9.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-extended/seabios/seabios_1.9.0.bb b/recipes-extended/seabios/seabios_1.9.0.bb
new file mode 100644
index 00000000..fcdc0c5b
--- /dev/null
+++ b/recipes-extended/seabios/seabios_1.9.0.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "SeaBIOS"
2HOMEPAGE = "http://www.coreboot.org/SeaBIOS"
3LICENSE = "LGPLv3"
4SECTION = "firmware"
5
6SRC_URI = " \
7 http://code.coreboot.org/p/seabios/downloads/get/${PN}-${PV}.tar.gz \
8 file://hostcc.patch \
9 file://defconfig \
10 "
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
13 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
14 "
15
16SRC_URI[md5sum] = "c3fea87e731e396bd4e7e2c478ba39d9"
17SRC_URI[sha256sum] = "88595545c6d580a7a6da1c40befc46dd74c0e4aaf808547867dd7ce8cc3b4d0e"
18
19FILES_${PN} = "/usr/share/firmware"
20
21DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native iasl-native python-native"
22
23TUNE_CCARGS = ""
24EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'"
25EXTRA_OEMAKE += "CROSS_PREFIX=${TARGET_PREFIX}"
26
27do_configure() {
28 install -m 0644 "${WORKDIR}/defconfig" .config
29 oe_runmake oldconfig
30}
31
32do_compile() {
33 unset CPP
34 unset CPPFLAGS
35 oe_runmake
36}
37
38do_install() {
39 oe_runmake
40 install -d ${D}/usr/share/firmware
41 install -m 0644 out/bios.bin ${D}/usr/share/firmware/
42}
43