summaryrefslogtreecommitdiffstats
path: root/recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch')
-rw-r--r--recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch b/recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch
new file mode 100644
index 00000000..014ed1d8
--- /dev/null
+++ b/recipes-extended/nagios/nagios-core/0001-fix-autoheader-error.patch
@@ -0,0 +1,63 @@
1From 3c51d942f6da08045351ce61cc7f426fa0855489 Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Fri, 31 Aug 2018 10:51:36 +0800
4Subject: [PATCH] fix autoheader error
5
6Upstream-Status: Pending
7
8Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
9---
10 configure.ac | 12 ++++++------
11 1 file changed, 6 insertions(+), 6 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index 17e436d..16b3e71 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -388,7 +388,7 @@ AC_ARG_WITH(iobroker,
18 case $IOBROKER_METHOD in
19 epoll*)
20 if test "$GLIBC_NEWER_2_4" -eq 1 -a "x$ac_cv_header_sys_epoll_h" = "xyes"; then
21- AC_DEFINE([IOBROKER_USES_EPOLL])
22+ AC_DEFINE([IOBROKER_USES_EPOLL], [1], [iobroker uses epoll])
23 else
24 echo "\"epoll\" is not available as an iobroker method."
25 echo "Please use one of the other options."
26@@ -397,7 +397,7 @@ epoll*)
27 ;;
28 poll*)
29 if test "x$ac_cv_header_sys_poll_h" = "xyes" -o "x$ac_cv_header_poll_h" = "xyes"; then
30- AC_DEFINE([IOBROKER_USES_POLL])
31+ AC_DEFINE([IOBROKER_USES_POLL], [1], [iobroker uses poll])
32 else
33 echo "\"poll\" is not available as an iobroker method."
34 echo "Please use one of the other options."
35@@ -406,7 +406,7 @@ poll*)
36 ;;
37 select*)
38 if test "x$ac_cv_header_sys_select_h" = "xyes"; then
39- AC_DEFINE([IOBROKER_USES_SELECT])
40+ AC_DEFINE([IOBROKER_USES_SELECT], [1], [iobroker uses select])
41 else
42 echo "\"select\" is not available as an iobroker method."
43 echo "Please use one of the other options."
44@@ -415,13 +415,13 @@ select*)
45 ;;
46 none*)
47 if test "$GLIBC_NEWER_2_4" -eq 1 -a "x$ac_cv_header_sys_epoll_h" = "xyes"; then
48- AC_DEFINE([IOBROKER_USES_EPOLL])
49+ AC_DEFINE([IOBROKER_USES_EPOLL], [1], [iobroker uses epoll])
50 IOBROKER_METHOD="epoll"
51 elif test "x$ac_cv_header_sys_poll_h" = "xyes" -o "x$ac_cv_header_poll_h" = "xyes"; then
52- AC_DEFINE([IOBROKER_USES_POLL])
53+ AC_DEFINE([IOBROKER_USES_POLL], [1], [iobroker uses poll])
54 IOBROKER_METHOD="poll"
55 elif test "x$ac_cv_header_sys_select_h" = "xyes"; then
56- AC_DEFINE([IOBROKER_USES_SELECT])
57+ AC_DEFINE([IOBROKER_USES_SELECT], [1], [iobroker uses select])
58 IOBROKER_METHOD="select"
59 else
60 echo "There are no available options for iobroker polling"
61--
622.7.4
63