summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch')
-rw-r--r--recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
new file mode 100644
index 00000000..91410449
--- /dev/null
+++ b/recipes-extended/libvirt/libvirt/tools-add-libvirt-net-rpc-to-virt-host-validate-when.patch
@@ -0,0 +1,112 @@
1From dade75d1ce25df6ab61867250d7adb65b4912090 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Fri, 2 Aug 2013 11:38:43 -0400
4Subject: [PATCH] tools: add libvirt-net-rpc to virt-host-validate when TLS is
5 enabled
6
7When gnu-tls is enabled for libvirt references to virNetTLSInit are
8generated in libvirt. Any binaries linking against libvirt, must also
9link against libvirt-net-rpc which provides the implementation.
10
11Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
12---
13 examples/dominfo/Makefile.am | 7 +++++++
14 examples/domsuspend/Makefile.am | 7 +++++++
15 examples/hellolibvirt/Makefile.am | 7 +++++++
16 examples/openauth/Makefile.am | 6 ++++++
17 tools/Makefile.am | 13 +++++++++++++
18 5 files changed, 40 insertions(+)
19
20diff --git a/examples/dominfo/Makefile.am b/examples/dominfo/Makefile.am
21index 4a30c7768df9..99b3e17eb741 100644
22--- a/examples/dominfo/Makefile.am
23+++ b/examples/dominfo/Makefile.am
24@@ -23,3 +23,10 @@ noinst_PROGRAMS=info1
25 info1_SOURCES=info1.c
26 info1_LDFLAGS=
27 info1_LDADD= $(LDADDS)
28+
29+if WITH_GNUTLS
30+info1_LDADD += $(top_builddir)/src/libvirt-net-rpc.la \
31+ $(top_builddir)/gnulib/lib/libgnu.la \
32+ $(NULL)
33+endif
34+
35diff --git a/examples/domsuspend/Makefile.am b/examples/domsuspend/Makefile.am
36index b8e65f24a28d..9553e0f1d948 100644
37--- a/examples/domsuspend/Makefile.am
38+++ b/examples/domsuspend/Makefile.am
39@@ -25,3 +25,10 @@ noinst_PROGRAMS=suspend
40 suspend_SOURCES=suspend.c
41 suspend_LDFLAGS=
42 suspend_LDADD= $(LDADDS)
43+
44+if WITH_GNUTLS
45+suspend_LDADD += $(top_builddir)/src/libvirt-net-rpc.la \
46+ $(top_builddir)/gnulib/lib/libgnu.la \
47+ $(NULL)
48+endif
49+
50diff --git a/examples/hellolibvirt/Makefile.am b/examples/hellolibvirt/Makefile.am
51index 55ea972c42f8..a5272e2bb565 100644
52--- a/examples/hellolibvirt/Makefile.am
53+++ b/examples/hellolibvirt/Makefile.am
54@@ -19,3 +19,10 @@ noinst_PROGRAMS = hellolibvirt
55 hellolibvirt_CFLAGS = $(WARN_CFLAGS)
56 hellolibvirt_SOURCES = hellolibvirt.c
57 hellolibvirt_LDADD = $(top_builddir)/src/libvirt.la
58+
59+if WITH_GNUTLS
60+hellolibvirt_LDADD += $(top_builddir)/src/libvirt-net-rpc.la \
61+ $(top_builddir)/gnulib/lib/libgnu.la \
62+ $(NULL)
63+endif
64+
65diff --git a/examples/openauth/Makefile.am b/examples/openauth/Makefile.am
66index 7bb860491e73..34e9b47f65cb 100644
67--- a/examples/openauth/Makefile.am
68+++ b/examples/openauth/Makefile.am
69@@ -19,3 +19,9 @@ noinst_PROGRAMS = openauth
70 openauth_CFLAGS = $(WARN_CFLAGS)
71 openauth_SOURCES = openauth.c
72 openauth_LDADD = $(top_builddir)/src/libvirt.la
73+if WITH_GNUTLS
74+openauth_LDADD += $(top_builddir)/src/libvirt-net-rpc.la \
75+ $(top_builddir)/gnulib/lib/libgnu.la \
76+ $(NULL)
77+endif
78+
79diff --git a/tools/Makefile.am b/tools/Makefile.am
80index 256a8f37a2a9..837a83fb612a 100644
81--- a/tools/Makefile.am
82+++ b/tools/Makefile.am
83@@ -147,6 +147,13 @@ virt_host_validate_LDADD = \
84 ../gnulib/lib/libgnu.la \
85 $(NULL)
86
87+if WITH_GNUTLS
88+virt_host_validate_LDADD += ../src/libvirt-net-rpc.la \
89+ ../gnulib/lib/libgnu.la \
90+ $(NULL)
91+endif
92+
93+
94 virt_host_validate_CFLAGS = \
95 $(WARN_CFLAGS) \
96 $(PIE_CFLAGS) \
97@@ -214,6 +221,12 @@ virsh_CFLAGS = \
98 $(READLINE_CFLAGS)
99 BUILT_SOURCES =
100
101+if WITH_GNUTLS
102+virsh_LDADD += ../src/libvirt-net-rpc.la \
103+ ../gnulib/lib/libgnu.la \
104+ $(NULL)
105+endif
106+
107 if WITH_WIN_ICON
108 virsh_LDADD += virsh_win_icon.$(OBJEXT)
109
110--
1111.8.1.2
112