summaryrefslogtreecommitdiffstats
path: root/recipes-extended/kvmtool/kvmtool_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/kvmtool/kvmtool_git.bb')
-rw-r--r--recipes-extended/kvmtool/kvmtool_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-extended/kvmtool/kvmtool_git.bb b/recipes-extended/kvmtool/kvmtool_git.bb
new file mode 100644
index 00000000..141fb02d
--- /dev/null
+++ b/recipes-extended/kvmtool/kvmtool_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Native Linux KVM tool"
2DESCRIPTION = "kvmtool is a lightweight tool for hosting KVM guests."
3
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
6
7DEPENDS = "dtc libaio zlib"
8do_configure[depends] += "virtual/kernel:do_shared_workdir"
9
10inherit kernel-arch
11
12SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git;branch=master \
13 file://external-crosscompiler.patch \
14 file://0001-kvmtool-9p-fixed-compilation-error.patch \
15 file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \
16 file://0003-kvmtool-Werror-disabled.patch \
17 "
18
19SRCREV = "4d2c017f41533b0e51e00f689050c26190a15318"
20PV = "5.10.0+git"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OEMAKE='V=1 EXTRA_CFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated -I${STAGING_KERNEL_BUILDDIR}/arch/${ARCH}/include/generated"'
25
26do_install() {
27 install -d ${D}${bindir}
28 install -m 0755 ${S}/lkvm ${D}${bindir}/
29}