summaryrefslogtreecommitdiffstats
path: root/recipes-extended/kvmtool/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/kvmtool/files')
-rw-r--r--recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch27
-rw-r--r--recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch29
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch
new file mode 100644
index 00000000..63911fc2
--- /dev/null
+++ b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch
@@ -0,0 +1,27 @@
1From bcd954ffdb9383030e02d356b51e09e4e2a7105a Mon Sep 17 00:00:00 2001
2From: Dariusz Pelowski <dariusz.pelowski@gmail.com>
3Date: Sun, 5 Nov 2017 12:39:52 +0100
4Subject: [PATCH 1/2] kvmtool: 9p: fixed compilation error
5
6makedev is defined in sys/sysmacros.h
7
8Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com>
9---
10 virtio/9p.c | 1 +
11 1 file changed, 1 insertion(+)
12
13diff --git a/virtio/9p.c b/virtio/9p.c
14index 6acbfdd..1dee2c2 100644
15--- a/virtio/9p.c
16+++ b/virtio/9p.c
17@@ -15,6 +15,7 @@
18 #include <string.h>
19 #include <errno.h>
20 #include <sys/vfs.h>
21+#include <sys/sysmacros.h>
22
23 #include <linux/virtio_ring.h>
24 #include <linux/virtio_9p.h>
25--
262.15.0
27
diff --git a/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch
new file mode 100644
index 00000000..262531ca
--- /dev/null
+++ b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch
@@ -0,0 +1,29 @@
1From 977a4d41012d1814f5a5330cacc2e4944de387cc Mon Sep 17 00:00:00 2001
2From: Dariusz Pelowski <dariusz.pelowski@gmail.com>
3Date: Sun, 5 Nov 2017 12:39:21 +0100
4Subject: [PATCH 2/2] kvmtool: add EXTRA_CFLAGS variable
5
6to avoid CFLAGS overriding introduce new EXTRA_CFLAGS variable
7for setting via command argument
8
9Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com>
10---
11 Makefile | 2 ++
12 1 file changed, 2 insertions(+)
13
14diff --git a/Makefile b/Makefile
15index 64a0a16..bca1b26 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -2,6 +2,8 @@
19 # Define WERROR=0 to disable -Werror.
20 #
21
22+CFLAGS += $(EXTRA_CFLAGS)
23+
24 ifeq ($(strip $(V)),)
25 E = @echo
26 Q = @
27--
282.15.0
29