summaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/xvisor-image-minimal.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/images/xvisor-image-minimal.bb')
-rw-r--r--recipes-extended/images/xvisor-image-minimal.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-extended/images/xvisor-image-minimal.bb b/recipes-extended/images/xvisor-image-minimal.bb
new file mode 100644
index 00000000..4c4a2fc2
--- /dev/null
+++ b/recipes-extended/images/xvisor-image-minimal.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "A minimal Xvisor image"
2
3INITRD_IMAGE = "core-image-minimal-initramfs"
4
5IMAGE_INSTALL += " \
6 packagegroup-core-boot \
7 packagegroup-core-ssh-openssh \
8 "
9
10# The hypervisor may not be within the dom0 filesystem image but at least
11# ensure that it is deployable:
12do_build[depends] += "xvisor:do_deploy"
13
14LICENSE = "MIT"
15
16inherit core-image
17
18# Enable runqemu. eg: runqemu xvisor-image-minimal nographic slirp
19QB_DEFAULT_KERNEL = "vmm.bin"
20QB_OPT_APPEND_append_riscv64 = " -cpu rv64,x-h=true "