summaryrefslogtreecommitdiffstats
path: root/recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch')
-rw-r--r--recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch126
1 files changed, 0 insertions, 126 deletions
diff --git a/recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch b/recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch
deleted file mode 100644
index f40e0eb5..00000000
--- a/recipes-extended/diod/files/0001-build-allow-builds-to-work-with-separate-build-dir.patch
+++ /dev/null
@@ -1,126 +0,0 @@
1From 43403468298ef4167baa5d84de2ee2eaf7f4007a Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Fri, 9 Jan 2015 18:34:04 +0000
4Subject: [PATCH 1/2] build: allow builds to work with separate build dir
5
6Remove assumptions in include paths that assume the build
7is happening in the source directories.
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
12---
13 diod/Makefile.am | 2 +-
14 libdiod/Makefile.am | 2 +-
15 liblsd/Makefile.am | 2 +-
16 libnpclient/Makefile.am | 2 +-
17 scripts/Makefile.am | 6 +++---
18 tests/kern/dbench/Makefile.am | 4 ++--
19 utils/Makefile.am | 2 +-
20 7 files changed, 10 insertions(+), 10 deletions(-)
21
22diff --git a/diod/Makefile.am b/diod/Makefile.am
23index 7644be7..fdaf130 100644
24--- a/diod/Makefile.am
25+++ b/diod/Makefile.am
26@@ -1,7 +1,7 @@
27 AM_CFLAGS = @GCCWARN@
28
29 AM_CPPFLAGS = \
30- -I../libnpfs -I../liblsd -I../libdiod
31+ -I$(srcdir)/../libnpfs -I$(srcdir)/../liblsd -I$(srcdir)/../libdiod
32
33 sbin_PROGRAMS = diod
34
35diff --git a/libdiod/Makefile.am b/libdiod/Makefile.am
36index 4810e14..6905cdd 100644
37--- a/libdiod/Makefile.am
38+++ b/libdiod/Makefile.am
39@@ -1,7 +1,7 @@
40 AM_CFLAGS = @GCCWARN@
41
42 AM_CPPFLAGS = \
43- -I../libnpfs -I../libnpclient -I../liblsd
44+ -I$(srcdir)/../libnpfs -I$(srcdir)/../libnpclient -I$(srcdir)/../liblsd
45
46 noinst_LIBRARIES = libdiod.a
47
48diff --git a/liblsd/Makefile.am b/liblsd/Makefile.am
49index c3e5658..7e18bf8 100644
50--- a/liblsd/Makefile.am
51+++ b/liblsd/Makefile.am
52@@ -1,6 +1,6 @@
53 AM_CFLAGS = @GCCWARN@
54
55-AM_CPPFLAGS = -I../libdiod
56+AM_CPPFLAGS = -I$(srcdir)/../libdiod
57
58 noinst_LIBRARIES = liblsd.a
59
60diff --git a/libnpclient/Makefile.am b/libnpclient/Makefile.am
61index 5305df9..cbaf266 100644
62--- a/libnpclient/Makefile.am
63+++ b/libnpclient/Makefile.am
64@@ -1,7 +1,7 @@
65 AM_CFLAGS = @GCCWARN@
66
67 AM_CPPFLAGS = \
68- -I../libnpfs
69+ -I$(srcdir)/../libnpfs
70
71 noinst_LIBRARIES = libnpclient.a
72
73diff --git a/scripts/Makefile.am b/scripts/Makefile.am
74index 51c24a3..2aba728 100644
75--- a/scripts/Makefile.am
76+++ b/scripts/Makefile.am
77@@ -1,9 +1,9 @@
78-systemddir=$(sysconfdir)/systemd/system
79+systemddir=/lib/systemd/system
80
81 install-data-local:
82- $(top_srcdir)/config/install-sh -m 755 $(srcdir)/auto.diod \
83+ $(top_srcdir)/config/install-sh -m 755 ./auto.diod \
84 $(DESTDIR)$(sysconfdir)/auto.diod
85- $(top_srcdir)/config/install-sh -m 755 $(srcdir)/diod.service \
86+ $(top_srcdir)/config/install-sh -m 644 ./diod.service \
87 $(DESTDIR)$(systemddir)/diod.service
88
89 uninstall-local:
90diff --git a/tests/kern/dbench/Makefile.am b/tests/kern/dbench/Makefile.am
91index e0cdefa..1704f9f 100644
92--- a/tests/kern/dbench/Makefile.am
93+++ b/tests/kern/dbench/Makefile.am
94@@ -2,7 +2,7 @@ AM_CFLAGS = -w
95
96 # VERSION=4.00
97
98-AM_CPPFLAGS = -DDATADIR=\"$(X_DATADIR)\"
99+AM_CPPFLAGS = -I. -DDATADIR=\"$(X_DATADIR)\"
100
101 LDADD = $(LIBPOPT)
102
103@@ -25,6 +25,6 @@ BUILT_SOURCES = proto.h
104 CLEANFILES = proto.h
105
106 proto.h: $(dbench_SOURCES) mkproto.pl
107- perl mkproto.pl $(dbench_SOURCES) > proto.h
108+ $(srcdir)/mkproto.pl $(patsubst %,$(srcdir),$(dbench_SOURCES)) > proto.h
109
110 EXTRA_DIST = mkproto.pl
111diff --git a/utils/Makefile.am b/utils/Makefile.am
112index 169b6c4..91d571d 100644
113--- a/utils/Makefile.am
114+++ b/utils/Makefile.am
115@@ -1,7 +1,7 @@
116 AM_CFLAGS = @GCCWARN@
117
118 AM_CPPFLAGS = \
119- -I../libnpfs -I../liblsd -I../libdiod -I../libnpclient
120+ -I$(srcdir)/../libnpfs -I$(srcdir)/../liblsd -I$(srcdir)/../libdiod -I$(srcdir)/../libnpclient
121
122 sbin_PROGRAMS = diodmount diodcat dtop diodload diodls diodshowmount dioddate
123
124--
1252.11.0
126