summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dev86/dev86_0.16.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dev86/dev86_0.16.19.bb')
-rw-r--r--recipes-extended/dev86/dev86_0.16.19.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-extended/dev86/dev86_0.16.19.bb b/recipes-extended/dev86/dev86_0.16.19.bb
new file mode 100644
index 00000000..807504ed
--- /dev/null
+++ b/recipes-extended/dev86/dev86_0.16.19.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)"
2HOMEPAGE = "http://www.debath.co.uk/dev86/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
5SECTION = "console/tools"
6PR="r0"
7
8SRC_URI="http://www.debath.co.uk/dev86/Dev86src-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "442e98e1afa23fe00d40c5a996385942"
11SRC_URI[sha256sum] = "33398b87ca85e2b69e4062cf59f2f7354af46da5edcba036c6f97bae17b8d00e"
12
13S = "${WORKDIR}/dev86-${PV}"
14
15BBCLASSEXTEND = "native"
16EXTRA_OEMAKE = "VERSION=${PV} PREFIX=${prefix} DIST=${D}"
17
18do_compile() {
19
20 oe_runmake make.fil
21 oe_runmake -f make.fil bcc86 as86 ld86
22
23}
24
25do_install() {
26
27 if [ "${prefix}"=="" ] ; then
28 export prefix=/usr
29 fi
30
31 oe_runmake install-bcc
32 ln -s ../lib/bcc/bcc-cpp ${D}${prefix}/bin/bcc-cpp
33 ln -s ../lib/bcc/bcc-cc1 ${D}${prefix}/bin/bcc-cc1
34
35}
36COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
37FILES_${PN} += "${libdir}/bcc"