summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph_13.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ceph/ceph_13.2.2.bb')
-rw-r--r--recipes-extended/ceph/ceph_13.2.2.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph_13.2.2.bb b/recipes-extended/ceph/ceph_13.2.2.bb
new file mode 100644
index 00000000..6c6da41b
--- /dev/null
+++ b/recipes-extended/ceph/ceph_13.2.2.bb
@@ -0,0 +1,90 @@
1SUMMARY = "User space components of the Ceph file system"
2LICENSE = "LGPLv2.1 & GPLv2 & Apache-2.0 & MIT"
3LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \
4 file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING;md5=92d301c8fccd296f2221a68a8dd53828 \
6"
7inherit cmake pythonnative python-dir systemd
8# Disable python pybind support for ceph temporary, when corss compiling pybind,
9# pybind mix cmake and python setup environment, would case a lot of errors.
10
11SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
12 file://0001-Correct-the-path-to-find-version.h-in-rocksdb.patch \
13 file://0001-zstd-fix-error-for-cross-compile.patch \
14 file://0001-ceph-add-pybind-support-in-OE.patch \
15 file://ceph.conf \
16"
17SRC_URI[md5sum] = "ce118be451dcb6b89e9e0a45057827dd"
18SRC_URI[sha256sum] = "f3a61db4c90e00c38a2dac7239b956ec367ef56f601e07335ed3011f931d8840"
19
20DEPENDS = "boost bzip2 curl expat gperf-native \
21 keyutils libaio libibverbs lz4 \
22 nspr nss \
23 oath openldap openssl \
24 python python-cython-native rocksdb snappy udev \
25 valgrind xfsprogs zlib \
26"
27SYSTEMD_SERVICE_${PN} = "ceph-radosgw@.service \
28 ceph-mon@.service \
29 ceph-mds@.service \
30 ceph-disk@.service \
31 ceph-osd@.service \
32 ceph.target \
33"
34OECMAKE_GENERATOR = "Unix Makefiles"
35
36EXTRA_OECMAKE = "-DWITH_MANPAGE=OFF \
37 -DWITH_FUSE=OFF \
38 -DWITH_SPDK=OFF \
39 -DWITH_LEVELDB=OFF \
40 -DWITH_LTTNG=OFF \
41 -DWITH_BABELTRACE=OFF \
42 -DWITH_TESTS=OFF \
43 -DWITH_MGR=OFF \
44 -DWITH_MGR_DASHBOARD_FRONTEND=OFF \
45 -DWITH_SYSTEM_BOOST=ON \
46 -DWITH_SYSTEM_ROCKSDB=ON \
47"
48
49do_configure_prepend () {
50 echo "set( CMAKE_SYSROOT \"${RECIPE_SYSROOT}\" )" >> ${WORKDIR}/toolchain.cmake
51 echo "set( CMAKE_DESTDIR \"${D}\" )" >> ${WORKDIR}/toolchain.cmake
52 echo "set( PYTHON_SITEPACKAGES_DIR \"${PYTHON_SITEPACKAGES_DIR}\" )" >> ${WORKDIR}/toolchain.cmake
53}
54
55do_install_append () {
56 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph
57 install -d ${D}${sysconfdir}/ceph
58 install -m 644 ${WORKDIR}/ceph.conf ${D}${sysconfdir}/ceph/
59 install -d ${D}${systemd_unitdir}/system
60 mv ${D}${libexecdir}/systemd/system/ceph-radosgw@.service ${D}${systemd_unitdir}/system/ceph-radosgw@.service
61 mv ${D}${libexecdir}/systemd/system/ceph-mon@.service ${D}${systemd_unitdir}/system/ceph-mon@.service
62 mv ${D}${libexecdir}/systemd/system/ceph-mds@.service ${D}${systemd_unitdir}/system/ceph-mds@.service
63 mv ${D}${libexecdir}/systemd/system/ceph-disk@.service ${D}${systemd_unitdir}/system/ceph-disk@.service
64 mv ${D}${libexecdir}/systemd/system/ceph-osd@.service ${D}${systemd_unitdir}/system/ceph-osd@.service
65 mv ${D}${libexecdir}/systemd/system/ceph.target ${D}${systemd_unitdir}/system/ceph.target
66}
67
68FILES_${PN} += "\
69 ${libdir}/rados-classes/*.so.* \
70"
71FILES_${PN}-dev += "\
72 ${libdir}/ceph/compressor/*.so \
73 ${libdir}/rados-classes/*.so \
74 ${libdir}/ceph/*.so \
75"
76FILES_${PN}-python = "\
77 ${PYTHON_SITEPACKAGES_DIR}/* \
78"
79RDEPENDS_${PN} += "\
80 python \
81 python-misc \
82 python-modules \
83 python-prettytable \
84 ${PN}-python \
85"
86COMPATIBLE_HOST = "(x86_64).*"
87PACKAGES += " \
88 ${PN}-python \
89"
90INSANE_SKIP_${PN}-python += "ldflags"