summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph_13.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ceph/ceph_13.2.1.bb')
-rw-r--r--recipes-extended/ceph/ceph_13.2.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph_13.2.1.bb b/recipes-extended/ceph/ceph_13.2.1.bb
new file mode 100644
index 00000000..d7186b94
--- /dev/null
+++ b/recipes-extended/ceph/ceph_13.2.1.bb
@@ -0,0 +1,62 @@
1SUMMARY = "User space components of the Ceph file system"
2LICENSE = "LGPLv2.1 & GPLv2 & Unknown & Apache-2.0 & MIT"
3LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \
4 file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING;md5=92d301c8fccd296f2221a68a8dd53828 \
6"
7
8# Disable python pybind support for ceph temporary, when corss compiling pybind,
9# pybind mix cmake and python setup environment, would case a lot of errors.
10
11SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
12 file://0001-Correct-the-path-to-find-version.h-in-rocksdb.patch \
13 file://0001-ceph-disable-pybind.patch \
14 file://0001-zstd-fix-error-for-cross-compile.patch \
15"
16SRC_URI[md5sum] = "4b0ee225e153fbb2515fa3f8a3666d17"
17SRC_URI[sha256sum] = "32086294d2007fdf64f85fcd919de2f092eeaa897bd8dc7c01e005e14516903c"
18
19DEPENDS = "boost bzip2 curl expat gperf-native \
20 keyutils libaio libibverbs lz4 \
21 nspr nss \
22 oath openldap openssl \
23 python rocksdb snappy udev \
24 valgrind xfsprogs zlib \
25"
26inherit cmake pythonnative python-dir
27OECMAKE_GENERATOR = "Unix Makefiles"
28
29EXTRA_OECMAKE = "-DWITH_MANPAGE=OFF \
30 -DWITH_FUSE=OFF \
31 -DWITH_SPDK=OFF \
32 -DWITH_LEVELDB=OFF \
33 -DWITH_LTTNG=OFF \
34 -DWITH_BABELTRACE=OFF \
35 -DWITH_TESTS=OFF \
36 -DWITH_MGR=OFF \
37 -DWITH_MGR_DASHBOARD_FRONTEND=OFF \
38 -DWITH_SYSTEM_BOOST=ON \
39 -DWITH_SYSTEM_ROCKSDB=ON \
40"
41
42do_configure_prepend () {
43 echo "set( CMAKE_SYSROOT \"${RECIPE_SYSROOT}\" )" >> ${WORKDIR}/toolchain.cmake
44}
45
46do_install_append () {
47 sed -i -e 's:${WORKDIR}.*python2:${bindir}/python:' ${D}${bindir}/ceph
48}
49
50FILES_${PN} += "\
51 ${libdir}/rados-classes/*.so.* \
52"
53
54FILES_${PN}-dev += "\
55 ${libdir}/ceph/compressor/*.so \
56 ${libdir}/rados-classes/*.so \
57 ${libdir}/ceph/*.so \
58"
59
60RDEPENDS_${PN} += "\
61 python \
62"