summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch')
-rw-r--r--recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch189
1 files changed, 0 insertions, 189 deletions
diff --git a/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch b/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
deleted file mode 100644
index 9686becb..00000000
--- a/recipes-extended/ceph/ceph/0001-ceph-fix-build-errors-for-cross-compile.patch
+++ /dev/null
@@ -1,189 +0,0 @@
1From 4712fe18405ffea31405308357a8e7fca358bcce Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Mon, 11 Mar 2019 09:14:09 +0800
4Subject: [PATCH] ceph: fix build errors for cross compile
5
61. set the cross compile sysroot to find the rocksdb library
72. correct the install path for library in Distutils.cmake
8
9Upstream-Status: Inappropriate [oe specific]
10
11Signed-off-by: Dengke Du <dengke.du@windriver.com>
12
13Adjust context for v14.2.3
14
15Signed-off-by: He Zhe <zhe.he@windriver.com>
16Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
17---
18 cmake/modules/Distutils.cmake | 25 +++++--------------------
19 cmake/modules/FindRocksDB.cmake | 4 ++--
20 src/compressor/zstd/CMakeLists.txt | 2 +-
21 src/pybind/cephfs/setup.py | 8 --------
22 src/pybind/rados/setup.py | 8 --------
23 src/pybind/rbd/setup.py | 8 --------
24 src/pybind/rgw/setup.py | 8 --------
25 7 files changed, 8 insertions(+), 55 deletions(-)
26
27Index: ceph-18.2.0/cmake/modules/Distutils.cmake
28===================================================================
29--- ceph-18.2.0.orig/cmake/modules/Distutils.cmake
30+++ ceph-18.2.0/cmake/modules/Distutils.cmake
31@@ -29,17 +29,10 @@
32 cmake_parse_arguments(DU "" "INSTALL_SCRIPT" "" ${ARGN})
33 install(CODE "
34 set(options --prefix=${CMAKE_INSTALL_PREFIX})
35- if(DEFINED ENV{DESTDIR})
36- if(EXISTS /etc/debian_version)
37- list(APPEND options --install-layout=deb)
38- endif()
39- list(APPEND options
40- --root=\$ENV{DESTDIR}
41- --single-version-externally-managed)
42- endif()
43 if(NOT \"${DU_INSTALL_SCRIPT}\" STREQUAL \"\")
44 list(APPEND options --install-script=${DU_INSTALL_SCRIPT})
45- endif()
46+ list(APPEND options --root=${CMAKE_DESTDIR})
47+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
48 execute_process(
49 COMMAND ${Python3_EXECUTABLE}
50 setup.py install \${options}
51@@ -65,7 +58,7 @@
52 if(DU_DISABLE_VTA AND HAS_VTA)
53 list(APPEND PY_CFLAGS -fno-var-tracking-assignments)
54 endif()
55- list(APPEND PY_CPPFLAGS -iquote${CMAKE_SOURCE_DIR}/src/include -w)
56+ list(APPEND PY_CPPFLAGS -iquote${CMAKE_SOURCE_DIR}/src/include -w --sysroot=${CMAKE_SYSROOT})
57 # This little bit of magic wipes out __Pyx_check_single_interpreter()
58 # Note: this is reproduced in distutils_install_cython_module
59 list(APPEND PY_CPPFLAGS -D'void0=dead_function\(void\)')
60@@ -135,14 +128,8 @@
61 set(ENV{CEPH_LIBDIR} \"${CMAKE_LIBRARY_OUTPUT_DIRECTORY}\")
62
63 set(options --prefix=${CMAKE_INSTALL_PREFIX})
64- if(DEFINED ENV{DESTDIR})
65- if(EXISTS /etc/debian_version)
66- list(APPEND options --install-layout=deb)
67- endif()
68- list(APPEND options --root=\$ENV{DESTDIR})
69- else()
70- list(APPEND options --root=/)
71- endif()
72+ list(APPEND options --root=${CMAKE_DESTDIR})
73+ list(APPEND options --install-lib=${PYTHON_SITEPACKAGES_DIR})
74 execute_process(
75 COMMAND
76 ${Python3_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/setup.py
77Index: ceph-18.2.0/cmake/modules/FindRocksDB.cmake
78===================================================================
79--- ceph-18.2.0.orig/cmake/modules/FindRocksDB.cmake
80+++ ceph-18.2.0/cmake/modules/FindRocksDB.cmake
81@@ -9,9 +9,9 @@
82 # ROCKSDB_VERSION_MINOR
83 # ROCKSDB_VERSION_PATCH
84
85-find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h)
86+find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h ${CMAKE_SYSROOT})
87
88-find_library(ROCKSDB_LIBRARIES rocksdb)
89+find_library(ROCKSDB_LIBRARIES rocksdb ${CMAKE_SYSROOT})
90
91 if(ROCKSDB_INCLUDE_DIR AND EXISTS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h")
92 foreach(ver "MAJOR" "MINOR" "PATCH")
93Index: ceph-18.2.0/src/pybind/cephfs/setup.py
94===================================================================
95--- ceph-18.2.0.orig/src/pybind/cephfs/setup.py
96+++ ceph-18.2.0/src/pybind/cephfs/setup.py
97@@ -135,20 +135,6 @@
98 finally:
99 shutil.rmtree(tmp_dir)
100
101-
102-if 'BUILD_DOC' in os.environ or 'READTHEDOCS' in os.environ:
103- ext_args = {}
104- cython_constants = dict(BUILD_DOC=True)
105- cythonize_args = dict(compile_time_env=cython_constants)
106-elif check_sanity():
107- ext_args = get_python_flags(['cephfs'])
108- cython_constants = dict(BUILD_DOC=False)
109- include_path = [os.path.join(os.path.dirname(__file__), "..", "rados")]
110- cythonize_args = dict(compile_time_env=cython_constants,
111- include_path=include_path)
112-else:
113- sys.exit(1)
114-
115 cmdclass = {}
116 try:
117 from Cython.Build import cythonize
118Index: ceph-18.2.0/src/pybind/rados/setup.py
119===================================================================
120--- ceph-18.2.0.orig/src/pybind/rados/setup.py
121+++ ceph-18.2.0/src/pybind/rados/setup.py
122@@ -130,17 +130,6 @@
123 finally:
124 shutil.rmtree(tmp_dir)
125
126-
127-if 'BUILD_DOC' in os.environ or 'READTHEDOCS' in os.environ:
128- ext_args = {}
129- cython_constants = dict(BUILD_DOC=True)
130-elif check_sanity():
131- ext_args = get_python_flags(['rados'])
132- cython_constants = dict(BUILD_DOC=False)
133-else:
134- sys.exit(1)
135-
136-cmdclass = {}
137 try:
138 from Cython.Build import cythonize
139 from Cython.Distutils import build_ext
140Index: ceph-18.2.0/src/pybind/rbd/setup.py
141===================================================================
142--- ceph-18.2.0.orig/src/pybind/rbd/setup.py
143+++ ceph-18.2.0/src/pybind/rbd/setup.py
144@@ -133,20 +133,6 @@
145 finally:
146 shutil.rmtree(tmp_dir)
147
148-
149-if 'BUILD_DOC' in os.environ or 'READTHEDOCS' in os.environ:
150- ext_args = {}
151- cython_constants = dict(BUILD_DOC=True)
152- cythonize_args = dict(compile_time_env=cython_constants)
153-elif check_sanity():
154- ext_args = get_python_flags(['rados', 'rbd'])
155- cython_constants = dict(BUILD_DOC=False)
156- include_path = [os.path.join(os.path.dirname(__file__), "..", "rados")]
157- cythonize_args = dict(compile_time_env=cython_constants,
158- include_path=include_path)
159-else:
160- sys.exit(1)
161-
162 cmdclass = {}
163 try:
164 from Cython.Build import cythonize
165Index: ceph-18.2.0/src/pybind/rgw/setup.py
166===================================================================
167--- ceph-18.2.0.orig/src/pybind/rgw/setup.py
168+++ ceph-18.2.0/src/pybind/rgw/setup.py
169@@ -134,20 +134,6 @@
170 finally:
171 shutil.rmtree(tmp_dir)
172
173-
174-if 'BUILD_DOC' in os.environ or 'READTHEDOCS' in os.environ:
175- ext_args = {}
176- cython_constants = dict(BUILD_DOC=True)
177- cythonize_args = dict(compile_time_env=cython_constants)
178-elif check_sanity():
179- ext_args = get_python_flags(['rados', 'rgw'])
180- cython_constants = dict(BUILD_DOC=False)
181- include_path = [os.path.join(os.path.dirname(__file__), "..", "rados")]
182- cythonize_args = dict(compile_time_env=cython_constants,
183- include_path=include_path)
184-else:
185- sys.exit(1)
186-
187 cmdclass = {}
188 try:
189 from Cython.Build import cythonize