summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-docker_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-docker_3.4.0.bb')
-rw-r--r--recipes-devtools/python/python3-docker_3.4.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-docker_3.4.0.bb b/recipes-devtools/python/python3-docker_3.4.0.bb
new file mode 100644
index 00000000..6e813025
--- /dev/null
+++ b/recipes-devtools/python/python3-docker_3.4.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "02491d168c048cdb99cc20d0b352ea0f"
9SRC_URI[sha256sum] = "e9cc39e24905e67ba9e2df14c94488f5cf030fb72ae1c60de505ce5ea90503f7"
10
11DEPENDS += "${PYTHON_PN}-pip-native"
12
13RDEPENDS_${PN} += " \
14 python3-docker-pycreds \
15 python3-requests \
16 python3-websocket-client \
17"