summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-context_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/go/go-context_git.bb')
-rw-r--r--recipes-devtools/go/go-context_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-context_git.bb b/recipes-devtools/go/go-context_git.bb
new file mode 100644
index 00000000..a4b832e1
--- /dev/null
+++ b/recipes-devtools/go/go-context_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "A golang registry for global request variables."
2HOMEPAGE = "https://github.com/gorilla/context"
3SECTION = "devel/go"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f"
6
7PR = "r0"
8SRCNAME = "context"
9
10PKG_NAME = "github.com/gorilla/${SRCNAME}"
11SRC_URI = "git://${PKG_NAME}.git"
12
13SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
19 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
20}
21
22SYSROOT_PREPROCESS_FUNCS += "go_context_sysroot_preprocess"
23
24go_context_sysroot_preprocess () {
25 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
26 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
27}
28
29FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"