summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/runv/runv_git.bb87
-rw-r--r--recipes-core/sysvinit/sysvinit-inittab_virtualization.inc2
2 files changed, 1 insertions, 88 deletions
diff --git a/recipes-core/runv/runv_git.bb b/recipes-core/runv/runv_git.bb
deleted file mode 100644
index 73cd81a6..00000000
--- a/recipes-core/runv/runv_git.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1HOMEPAGE = "https://github.com/hyperhq/runv"
2SUMMARY = "Hypervisor-based Runtime for OCI"
3DESCRIPTION = "Hypervisor-based Runtime for OCI"
4
5SRCREV_runv = "b360a686abc6c6e896382990ef1b93ef07c7a677"
6SRC_URI = "\
7 git://github.com/hyperhq/runv.git;nobranch=1;name=runv;protocol=https \
8 "
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4106a50540bdec3b9734f9c70882d382"
12
13GO_IMPORT = "import"
14
15PV = "0.4.0+git${SRCREV_runv}"
16
17inherit go
18inherit goarch
19inherit pkgconfig
20inherit autotools-brokensep
21
22# accord with qemu
23COMPATIBLE_HOST:mipsarchn32 = "null"
24COMPATIBLE_HOST:mipsarchn64 = "null"
25COMPATIBLE_HOST:riscv32 = "null"
26COMPATIBLE_HOST:powerpc = "null"
27
28PACKAGECONFIG[xen] = "--with-xen,--without-xen,"
29AUTOTOOLS_SCRIPT_PATH = "${S}/src/import/"
30
31RDEPENDS:${PN} += " qemu hyperstart"
32
33do_compile() {
34 export GOARCH="${TARGET_GOARCH}"
35 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
36 export GOPATH="${S}/src/import:${S}/src/import/vendor"
37
38 # Pass the needed cflags/ldflags so that cgo
39 # can find the needed headers files and libraries
40 export CGO_ENABLED="1"
41 export CFLAGS=""
42 export LDFLAGS=""
43 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
44 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
45
46 # link fixups for compilation
47 rm -f ${S}/src/import/vendor/src
48 ln -sf ./ ${S}/src/import/vendor/src
49
50 mkdir -p ${S}/src/import/vendor/github.com/hyperhq/runv
51
52 echo fff
53 pwd
54 ln -sf src/import/cli
55 ln -sf ../../../../api ${S}/src/import/vendor/github.com/hyperhq/runv/api
56 ln -sf ../../../../cli ${S}/src/import/vendor/github.com/hyperhq/runv/cli
57 ln -sf ../../../../lib ${S}/src/import/vendor/github.com/hyperhq/runv/lib
58 ln -sf ../../../../driverloader ${S}/src/import/vendor/github.com/hyperhq/runv/driverloader
59 ln -sf ../../../../factory ${S}/src/import/vendor/github.com/hyperhq/runv/factory
60 ln -sf ../../../../hyperstart ${S}/src/import/vendor/github.com/hyperhq/runv/hyperstart
61 ln -sf ../../../../hypervisor ${S}/src/import/vendor/github.com/hyperhq/runv/hypervisor
62 ln -sf ../../../../template ${S}/src/import/vendor/github.com/hyperhq/runv/template
63
64 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
65 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
66
67 # Pass the needed cflags/ldflags so that cgo
68 # can find the needed headers files and libraries
69 export CGO_ENABLED="1"
70 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
71 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
72
73 oe_runmake build-runv
74}
75
76do_install() {
77 localbindir="/usr/local/bin"
78
79 install -d ${D}${localbindir}
80 install -m 755 ${S}/runv ${D}/${localbindir}
81}
82
83deltask compile_ptest_base
84
85FILES:${PN} += "/usr/local/bin/*"
86
87INSANE_SKIP:${PN} += "ldflags already-stripped"
diff --git a/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc b/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
index bf52da0e..5010dfd3 100644
--- a/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
+++ b/recipes-core/sysvinit/sysvinit-inittab_virtualization.inc
@@ -4,6 +4,6 @@ SRC_URI += "file://getty-wrapper"
4 4
5do_install:append() { 5do_install:append() {
6 install -d ${D}${base_sbindir} 6 install -d ${D}${base_sbindir}
7 install -m 0755 ${WORKDIR}/getty-wrapper ${D}${base_sbindir}/getty-wrapper 7 install -m 0755 ${UNPACKDIR}/getty-wrapper ${D}${base_sbindir}/getty-wrapper
8} 8}
9FILES:${PN} += "${base_sbindir}/getty-wrapper" 9FILES:${PN} += "${base_sbindir}/getty-wrapper"