summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend5
-rw-r--r--recipes-core/busybox/busybox/getopt.cfg2
-rw-r--r--recipes-core/busybox/busybox/lspci.cfg1
-rw-r--r--recipes-core/busybox/busybox/lsusb.cfg1
-rw-r--r--recipes-core/busybox/busybox/mdev.cfg6
-rw-r--r--recipes-core/busybox/busybox/mount-cifs.cfg1
-rw-r--r--recipes-core/busybox/busybox/ps-extras.cfg3
-rw-r--r--recipes-core/busybox/busybox_1.22.1.bbappend10
-rw-r--r--recipes-core/initscripts/initscripts_1.0.bbappend16
-rw-r--r--recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bbappend6
10 files changed, 51 insertions, 0 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
new file mode 100644
index 00000000..eb973adf
--- /dev/null
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -0,0 +1,5 @@
1do_install_append() {
2 if echo "${DISTRO_FEATURES}" | grep -q 'xen'; then
3 echo "xenfs /proc/xen xenfs defaults 0 0" >> ${D}${sysconfdir}/fstab
4 fi
5}
diff --git a/recipes-core/busybox/busybox/getopt.cfg b/recipes-core/busybox/busybox/getopt.cfg
new file mode 100644
index 00000000..8dcd3504
--- /dev/null
+++ b/recipes-core/busybox/busybox/getopt.cfg
@@ -0,0 +1,2 @@
1CONFIG_GETOPT=y
2CONFIG_FEATURE_GETOPT_LONG=y
diff --git a/recipes-core/busybox/busybox/lspci.cfg b/recipes-core/busybox/busybox/lspci.cfg
new file mode 100644
index 00000000..6458af84
--- /dev/null
+++ b/recipes-core/busybox/busybox/lspci.cfg
@@ -0,0 +1 @@
CONFIG_LSPCI=y
diff --git a/recipes-core/busybox/busybox/lsusb.cfg b/recipes-core/busybox/busybox/lsusb.cfg
new file mode 100644
index 00000000..2aba6ef6
--- /dev/null
+++ b/recipes-core/busybox/busybox/lsusb.cfg
@@ -0,0 +1 @@
CONFIG_LSUSB=y
diff --git a/recipes-core/busybox/busybox/mdev.cfg b/recipes-core/busybox/busybox/mdev.cfg
new file mode 100644
index 00000000..f8d6da82
--- /dev/null
+++ b/recipes-core/busybox/busybox/mdev.cfg
@@ -0,0 +1,6 @@
1CONFIG_MDEV=y
2CONFIG_FEATURE_MDEV_CONF=y
3CONFIG_FEATURE_MDEV_RENAME=y
4CONFIG_FEATURE_MDEV_RENAME_REGEXP=y
5CONFIG_FEATURE_MDEV_EXEC=y
6CONFIG_FEATURE_MDEV_LOAD_FIRMWARE=y
diff --git a/recipes-core/busybox/busybox/mount-cifs.cfg b/recipes-core/busybox/busybox/mount-cifs.cfg
new file mode 100644
index 00000000..88f0404f
--- /dev/null
+++ b/recipes-core/busybox/busybox/mount-cifs.cfg
@@ -0,0 +1 @@
CONFIG_FEATURE_MOUNT_CIFS=y
diff --git a/recipes-core/busybox/busybox/ps-extras.cfg b/recipes-core/busybox/busybox/ps-extras.cfg
new file mode 100644
index 00000000..74346355
--- /dev/null
+++ b/recipes-core/busybox/busybox/ps-extras.cfg
@@ -0,0 +1,3 @@
1CONFIG_DESKTOP=y
2CONFIG_FEATURE_PS_TIME=y
3CONFIG_FEATURE_PS_ADDITIONAL_COLUMNS=y
diff --git a/recipes-core/busybox/busybox_1.22.1.bbappend b/recipes-core/busybox/busybox_1.22.1.bbappend
new file mode 100644
index 00000000..8369a031
--- /dev/null
+++ b/recipes-core/busybox/busybox_1.22.1.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://lspci.cfg \
5 file://lsusb.cfg \
6 file://mdev.cfg \
7 file://mount-cifs.cfg \
8 file://ps-extras.cfg \
9 file://getopt.cfg \
10 "
diff --git a/recipes-core/initscripts/initscripts_1.0.bbappend b/recipes-core/initscripts/initscripts_1.0.bbappend
new file mode 100644
index 00000000..0600ab2a
--- /dev/null
+++ b/recipes-core/initscripts/initscripts_1.0.bbappend
@@ -0,0 +1,16 @@
1do_install_append() {
2
3 echo >> ${D}${sysconfdir}/init.d/functions
4 echo success \(\) \{ >> ${D}${sysconfdir}/init.d/functions
5 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
6 echo \} >> ${D}${sysconfdir}/init.d/functions
7 echo failure \(\) \{ >> ${D}${sysconfdir}/init.d/functions
8 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
9 echo \} >> ${D}${sysconfdir}/init.d/functions
10 echo warning \(\) \{ >> ${D}${sysconfdir}/init.d/functions
11 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
12 echo \} >> ${D}${sysconfdir}/init.d/functions
13 echo begin \(\) \{ >> ${D}${sysconfdir}/init.d/functions
14 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
15 echo \} >> ${D}${sysconfdir}/init.d/functions
16}
diff --git a/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bbappend b/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bbappend
new file mode 100644
index 00000000..1b89aecd
--- /dev/null
+++ b/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bbappend
@@ -0,0 +1,6 @@
1do_install_append() {
2 if echo "${DISTRO_FEATURES}" | grep -q 'xen'; then
3 echo "" >> ${D}${sysconfdir}/inittab
4 echo "X0:12345:respawn:/sbin/getty 115200 hvc0" >> ${D}${sysconfdir}/inittab
5 fi
6}