summaryrefslogtreecommitdiffstats
path: root/recipes-core/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/packagegroups')
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index d425ac58..b3b0d4c3 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -44,3 +44,12 @@ RDEPENDS_packagegroup-containerd = " \
44 virtual/containerd \ 44 virtual/containerd \
45" 45"
46 46
47python __anonymous() {
48 msg = ""
49 # ERROR: Nothing PROVIDES 'libseccomp' (but meta-virtualization/recipes-containers/podman/ DEPENDS on or otherwise requires it).
50 # ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
51 # Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'podman', 'libseccomp']
52 if 'security' not in d.getVar('BBFILE_COLLECTIONS').split():
53 msg += "Make sure meta-security should be present as it provides 'libseccomp'"
54 raise bb.parse.SkipRecipe(msg)
55}