diff options
Diffstat (limited to 'recipes-containers')
-rw-r--r-- | recipes-containers/docker/docker_git.bb | 12 |
1 files changed, 9 insertions, 3 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb index 69c45ae3..080e5743 100644 --- a/recipes-containers/docker/docker_git.bb +++ b/recipes-containers/docker/docker_git.bb | |||
@@ -84,10 +84,12 @@ do_compile() { | |||
84 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | 84 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" |
85 | cd - | 85 | cd - |
86 | 86 | ||
87 | export CGO_ENABLED="1" | ||
88 | |||
87 | # Pass the needed cflags/ldflags so that cgo | 89 | # Pass the needed cflags/ldflags so that cgo |
88 | # can find the needed headers files and libraries | 90 | # can find the needed headers files and libraries |
89 | export CGO_CFLAGS="${BUILD_CFLAGS}" | 91 | export CGO_CFLAGS="${BUILDSDK_CFLAGS}" |
90 | export CGO_LDFLAGS="${BUILD_LDFLAGS}" | 92 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS}" |
91 | 93 | ||
92 | # this is the unsupported built structure | 94 | # this is the unsupported built structure |
93 | # that doesn't rely on an existing docker | 95 | # that doesn't rely on an existing docker |
@@ -125,7 +127,11 @@ do_install() { | |||
125 | install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init | 127 | install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init |
126 | fi | 128 | fi |
127 | 129 | ||
128 | cp ${S}/vendor/bin/nsinit ${D}/${bindir} | 130 | if [ -d ${S}/vendor/bin/linux_* ]; then |
131 | cp ${S}/vendor/bin/linux_*/* ${D}/${bindir} | ||
132 | else | ||
133 | cp ${S}/vendor/bin/* ${D}/${bindir} | ||
134 | fi | ||
129 | 135 | ||
130 | mkdir -p ${D}/usr/share/docker/ | 136 | mkdir -p ${D}/usr/share/docker/ |
131 | cp ${WORKDIR}/hi.Dockerfile ${D}/usr/share/docker/ | 137 | cp ${WORKDIR}/hi.Dockerfile ${D}/usr/share/docker/ |