summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch')
-rw-r--r--recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch b/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch
new file mode 100644
index 00000000..14228d65
--- /dev/null
+++ b/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch
@@ -0,0 +1,47 @@
1From 66a71fbf94020651880f1dbb6e4663d93391b47c Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Mon, 10 Sep 2018 13:14:07 -0400
4Subject: [PATCH] systemd: allow for distinct build directory
5
6The Makefile.am is currently written in a way that doesn't allow for a
7distinct build directory. As such we get the error:
8
9 install: cannot stat 'lxcfs.service': No such file or directory
10
11Make use of $(srcdir) to correct this.
12
13Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
14---
15 config/init/systemd/Makefile.am | 2 +-
16 config/init/systemd/Makefile.in | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/config/init/systemd/Makefile.am b/config/init/systemd/Makefile.am
20index 79e96f5..d6933f9 100644
21--- a/config/init/systemd/Makefile.am
22+++ b/config/init/systemd/Makefile.am
23@@ -5,7 +5,7 @@ SYSTEMD_UNIT_DIR = /lib/systemd/system
24
25 install-systemd: lxcfs.service
26 $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
27- $(INSTALL_DATA) lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
28+ $(INSTALL_DATA) $(srcdir)/lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
29
30 uninstall-systemd:
31 rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/lxcfs.service
32diff --git a/config/init/systemd/Makefile.in b/config/init/systemd/Makefile.in
33index d433e8a..430190c 100644
34--- a/config/init/systemd/Makefile.in
35+++ b/config/init/systemd/Makefile.in
36@@ -450,7 +450,7 @@ uninstall-am: uninstall-local
37
38 @INIT_SCRIPT_SYSTEMD_TRUE@install-systemd: lxcfs.service
39 @INIT_SCRIPT_SYSTEMD_TRUE@ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
40-@INIT_SCRIPT_SYSTEMD_TRUE@ $(INSTALL_DATA) lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
41+@INIT_SCRIPT_SYSTEMD_TRUE@ $(INSTALL_DATA) $(srcdir)/lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
42
43 @INIT_SCRIPT_SYSTEMD_TRUE@uninstall-systemd:
44 @INIT_SCRIPT_SYSTEMD_TRUE@ rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/lxcfs.service
45--
462.7.4
47