summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/lxc_1.0.5.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-containers/lxc/lxc_1.0.5.bb b/recipes-containers/lxc/lxc_1.0.5.bb
index bea1ad08..04c027d4 100644
--- a/recipes-containers/lxc/lxc_1.0.5.bb
+++ b/recipes-containers/lxc/lxc_1.0.5.bb
@@ -37,10 +37,11 @@ S = "${WORKDIR}/${BPN}-${PV}"
37PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}" 37PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}"
38EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}" 38EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}"
39 39
40PACKAGECONFIG ??= "" 40PACKAGECONFIG ??= "templates"
41PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,," 41PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,,"
42PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,," 42PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,,"
43PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor" 43PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor"
44PACKAGECONFIG[templates] = ",,, ${PN}-templates"
44 45
45inherit autotools pkgconfig ptest 46inherit autotools pkgconfig ptest
46 47
@@ -48,6 +49,9 @@ FILES_${PN}-doc = "${mandir} ${infodir}"
48# For LXC the docdir only contains example configuration files and should be included in the lxc package 49# For LXC the docdir only contains example configuration files and should be included in the lxc package
49FILES_${PN} += "${docdir}" 50FILES_${PN} += "${docdir}"
50FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" 51FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"
52PACKAGES =+ "${PN}-templates"
53FILES_${PN}-templates += "${datadir}/lxc/templates"
54RDEPENDS_${PN}-templates += "bash"
51 55
52PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1" 56PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1"
53 57
@@ -59,6 +63,8 @@ do_install_append() {
59 echo "d root root 0755 ${localstatedir}/cache/lxc none" \ 63 echo "d root root 0755 ${localstatedir}/cache/lxc none" \
60 > ${D}${sysconfdir}/default/volatiles/99_lxc 64 > ${D}${sysconfdir}/default/volatiles/99_lxc
61 65
66 for i in `grep -l "#! */bin/bash" ${D}${datadir}/lxc/hooks/*`; do \
67 sed -e 's|#! */bin/bash|#!/bin/sh|' -i $i; done
62} 68}
63 69
64EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests" 70EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests"