summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-09-04 15:48:11 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-04 15:39:36 -0400
commitf5d690a773052c3406936d7e0f2e6af6b24c77c2 (patch)
tree99133beedc135043460dafa44d719d99cd2f0e95 /recipes-containers/lxc
parentb94455174264240bf8519e4148ea5f1fb38d55c6 (diff)
downloadmeta-virtualization-f5d690a773052c3406936d7e0f2e6af6b24c77c2.tar.gz
lxc: fix RDEPENDS on bash
Split a ${PN}-template pkg to put ${datadir}/lxc/templates/, and debash in ${datadir}/lxc/hooks/* since the checkbashisms shows there are no bashism, so use /bin/sh. checkbashisms is from devscripts package: http://packages.ubuntu.com/trusty/devscripts Bash scripts: lxc/usr/share/lxc/hooks/mountcgroups:#!/bin/bash lxc/usr/share/lxc/hooks/ubuntu-cloud-prep:#!/bin/bash lxc/usr/share/lxc/templates/lxc-debian:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-openmandriva:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-archlinux:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-centos:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-plamo:1:#!/bin/bash -eu lxc/usr/share/lxc/templates/lxc-ubuntu-cloud:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-opensuse:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-gentoo:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-altlinux:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-sshd:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-ubuntu:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-cirros:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-busybox:1:#!/bin/bash lxc/usr/share/lxc/templates/lxc-fedora:1:#!/bin/bash Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/lxc_1.0.5.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-containers/lxc/lxc_1.0.5.bb b/recipes-containers/lxc/lxc_1.0.5.bb
index bea1ad08..04c027d4 100644
--- a/recipes-containers/lxc/lxc_1.0.5.bb
+++ b/recipes-containers/lxc/lxc_1.0.5.bb
@@ -37,10 +37,11 @@ S = "${WORKDIR}/${BPN}-${PV}"
37PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}" 37PTEST_CONF = "${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-tests', '', d)}"
38EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}" 38EXTRA_OECONF += "--with-distro=${DISTRO} ${PTEST_CONF}"
39 39
40PACKAGECONFIG ??= "" 40PACKAGECONFIG ??= "templates"
41PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,," 41PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,,"
42PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,," 42PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath,,"
43PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor" 43PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor"
44PACKAGECONFIG[templates] = ",,, ${PN}-templates"
44 45
45inherit autotools pkgconfig ptest 46inherit autotools pkgconfig ptest
46 47
@@ -48,6 +49,9 @@ FILES_${PN}-doc = "${mandir} ${infodir}"
48# For LXC the docdir only contains example configuration files and should be included in the lxc package 49# For LXC the docdir only contains example configuration files and should be included in the lxc package
49FILES_${PN} += "${docdir}" 50FILES_${PN} += "${docdir}"
50FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" 51FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"
52PACKAGES =+ "${PN}-templates"
53FILES_${PN}-templates += "${datadir}/lxc/templates"
54RDEPENDS_${PN}-templates += "bash"
51 55
52PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1" 56PRIVATE_LIBS_${PN}-ptest = "liblxc.so.1"
53 57
@@ -59,6 +63,8 @@ do_install_append() {
59 echo "d root root 0755 ${localstatedir}/cache/lxc none" \ 63 echo "d root root 0755 ${localstatedir}/cache/lxc none" \
60 > ${D}${sysconfdir}/default/volatiles/99_lxc 64 > ${D}${sysconfdir}/default/volatiles/99_lxc
61 65
66 for i in `grep -l "#! */bin/bash" ${D}${datadir}/lxc/hooks/*`; do \
67 sed -e 's|#! */bin/bash|#!/bin/sh|' -i $i; done
62} 68}
63 69
64EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests" 70EXTRA_OEMAKE += "TEST_DIR=${D}${PTEST_PATH}/src/tests"