summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch')
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
new file mode 100644
index 00000000..61ddd26d
--- /dev/null
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -0,0 +1,62 @@
1From 04c07804930faad708218a3134c81de06a9c742a Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Fri, 6 Apr 2018 23:58:22 -0400
4Subject: [PATCH] libnetwork: use $(GO) instead of go
5
6Ensure that the libnetwork makefile uses the go cross flags and
7utilities.
8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
10---
11 Makefile | 14 +++++++-------
12 1 file changed, 7 insertions(+), 7 deletions(-)
13
14diff --git a/libnetwork/Makefile b/libnetwork/Makefile
15index 17060bc212c7..90cc7a72ef45 100644
16--- a/libnetwork/Makefile
17+++ b/libnetwork/Makefile
18@@ -26,9 +26,9 @@ build: ${build_image}.created
19 build-local:
20 @echo "🐳 $@"
21 @mkdir -p "bin"
22- go build -tags experimental -o "bin/dnet" ./cmd/dnet
23- go build -o "bin/docker-proxy" ./cmd/proxy
24- GOOS=linux go build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic
25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet
26+ $(GO) build -o "bin/proxy" ./cmd/proxy
27+ GOOS=linux $(GO) build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic
28
29 clean:
30 @echo "🐳 $@"
31@@ -51,8 +51,8 @@ cross: ${build_image}.created
32
33 cross-local:
34 @echo "🐳 $@"
35- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
36- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
39
40 check: ${build_image}.created
41 @${docker} ./wrapmake.sh check-local
42@@ -68,7 +68,7 @@ run-tests:
43 if ls $$dir/*.go &> /dev/null; then \
44 pushd . &> /dev/null ; \
45 cd $$dir ; \
46- go test ${INSIDECONTAINER} -test.parallel 5 -test.v -covermode=count -coverprofile=./profile.tmp ; \
47+ $(GO) test ${INSIDECONTAINER} -test.parallel 5 -test.v -covermode=count -coverprofile=./profile.tmp ; \
48 ret=$$? ;\
49 if [ $$ret -ne 0 ]; then exit $$ret; fi ;\
50 popd &> /dev/null; \
51@@ -94,7 +94,7 @@ coveralls:
52 # Depends on binaries because vet will silently fail if it can not load compiled imports
53 vet: ## run go vet
54 @echo "🐳 $@"
55- @test -z "$$(go vet ${PACKAGES} 2>&1 | grep -v 'constant [0-9]* not a string in call to Errorf' | egrep -v '(timestamp_test.go|duration_test.go|exit status 1)' | tee /dev/stderr)"
56+ @test -z "$$($(GO) vet ${PACKAGES} 2>&1 | grep -v 'constant [0-9]* not a string in call to Errorf' | egrep -v '(timestamp_test.go|duration_test.go|exit status 1)' | tee /dev/stderr)"
57
58 misspell:
59 @echo "🐳 $@"
60--
612.4.0.53.g8440f74
62